CVE-2025-54539 Apache ActiveMQ NMS AMQP Client: Deserialization of Untrusted Data

Critical 9.8 Published Updated

Malicious AMQP servers can trigger arbitrary code execution on clients using the Apache ActiveMQ NMS AMQP Client library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-54539?

CVE-2025-54539 is a critical unsafe deserialization vulnerability in Apache ActiveMQ NMS AMQP Client, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A Deserialization of Untrusted Data vulnerability exists in the Apache ActiveMQ NMS AMQP Client.

This issue affects all versions of Apache ActiveMQ NMS AMQP up to and including 2.3.0, when establishing connections to untrusted AMQP servers. Malicious servers could exploit unbounded deserialization logic present in the client to craft responses that may lead to arbitrary code execution on the client side.

Although version 2.1.0 introduced a mechanism to restrict deserialization via allow/deny lists, the protection was found to be bypassable under certain conditions.

In line with Microsoft’s deprecation of binary serialization in .NET 9, the project is evaluating the removal of .NET binary serialization support from the NMS API entirely in future releases.

Mitigation and Recommendations: Users are strongly encouraged to upgrade to version 2.4.0 or later, which resolves the issue. Additionally, projects depending on NMS-AMQP should migrate away from .NET binary serialization as part of a long-term hardening strategy.

Weakness: CWE-502

Which versions are affected by CVE-2025-54539?

2 open source packages ship an affected version, including Apache.NMS.AMQP. It affects 1 product.

PackageAffectedFixed in
Apache.NMS.AMQP NuGetAll versions2.4.0
Apache.NMS.AMQP NuGetAll versions2.4.0

Products include Apache Activemq Nms Amqp.

How do I fix CVE-2025-54539?

Upgrade Apache.NMS.AMQP to 2.4.0 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-54539 being exploited?

There is no known exploitation of CVE-2025-54539 in the wild and no public exploit code.

Sources

Also known as GHSA-4mjw-xr5x-prpc.

Is CVE-2025-54539 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free