{"answers":{"affected":"2 open source packages ship an affected version, including Apache.NMS.AMQP. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-54539 in the wild and no public exploit code.","fix":"Upgrade Apache.NMS.AMQP to 2.4.0 or later.","what":"CVE-2025-54539 is a critical unsafe deserialization vulnerability in Apache ActiveMQ NMS AMQP Client, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54539 and fix it if it is affected.\n\nWhat it is: CVE-2025-54539 is a critical unsafe deserialization vulnerability in Apache ActiveMQ NMS AMQP Client, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54539 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Apache.NMS.AMQP (NuGet): affected all versions; fixed in 2.4.0\n- Apache.NMS.AMQP (NuGet): affected all versions; fixed in 2.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54539/ (Markdown: https://insights.sbomify.com/CVE-2025-54539/index.md)","id":"CVE-2025-54539","markdown":"https://insights.sbomify.com/CVE-2025-54539/index.md","name":"CVE-2025-54539","record":{"aliases":["GHSA-4mjw-xr5x-prpc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"ActiveMQ NMS AMQP Client","requires_auth":"none","summary":"Malicious AMQP servers can trigger arbitrary code execution on clients using the Apache ActiveMQ NMS AMQP Client library.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"activemq_nms_amqp","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A Deserialization of Untrusted Data vulnerability exists in the Apache ActiveMQ NMS AMQP Client.\n\nThis issue affects all versions of Apache ActiveMQ NMS AMQP up to and including 2.3.0, when establishing connections to untrusted AMQP servers. Malicious servers could exploit unbounded deserialization logic present in the client to craft responses that may lead to arbitrary code execution on the client side.\n\nAlthough version 2.1.0 introduced a mechanism to restrict deserialization via allow/deny lists, the protection was found to be bypassable under certain conditions.\n\nIn line with Microsoft’s deprecation of binary serialization in .NET 9, the project is evaluating the removal of .NET binary serialization support from the NMS API entirely in future releases.\n\nMitigation and Recommendations:\nUsers are strongly encouraged to upgrade to version 2.4.0 or later, which resolves the issue. Additionally, projects depending on NMS-AMQP should migrate away from .NET binary serialization as part of a long-term hardening strategy.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ActiveMQ NMS AMQP Client: Deserialization of Untrusted Data","id":"CVE-2025-54539","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Reflected XSS in QuickCMS","id":"CVE-2025-54540"},"packages":[{"ecosystem":"NuGet","fixed":["2.4.0"],"introduced":["0"],"last_affected":[],"package":"Apache.NMS.AMQP","purl":null,"source":"GHSA-4mjw-xr5x-prpc"},{"ecosystem":"NuGet","fixed":["2.4.0"],"introduced":["0"],"last_affected":[],"package":"Apache.NMS.AMQP","purl":"pkg:nuget/Apache.NMS.AMQP","source":"GHSA-4mjw-xr5x-prpc"}],"prev":{"headline":"In JetBrains TeamCity before 2025.07 password exposure was possible via command line in the \"hg pull\" command","id":"CVE-2025-54538"},"products":["Apache ActiveMQ NMS AMQP Client"],"published":"2025-10-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["Apache Software Foundation"]},"summary":"Malicious AMQP servers can trigger arbitrary code execution on clients using the Apache ActiveMQ NMS AMQP Client library.","url":"https://insights.sbomify.com/CVE-2025-54539/"}