# CVE-2025-5455: Possible denial of service when passing malformed data in a URL to qDecodeDataUrl

> Attackers can cause a denial of service by passing malformed URLs to Qt's qDecodeDataUrl function when assertions are enabled.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H/R:U/RE:M/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jun 2025
- **Updated:** 29 Jul 2026
- **Also known as:** ALSA-2025:9462, ALSA-2025:9486, AZL-64349, AZL-64361, DEBIAN-CVE-2025-5455, ECHO-a29a-8133-4b8d, GHSA-5cfg-qhv9-4842, MGASA-2025-0212, OESA-2025-1654, OESA-2025-1655, OESA-2025-1725, OESA-2025-1757, OESA-2025-2545, RHSA-2025:11841, RHSA-2025:9462, RHSA-2025:9486, RLSA-2025:9462, RLSA-2025:9486, UBUNTU-CVE-2025-5455, openSUSE-SU-2025:15240-1

## What is CVE-2025-5455?

CVE-2025-5455 is a high-severity denial of service vulnerability in Qt, published on 2 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was found in the private API function qDecodeDataUrl() in QtCore, which is used in QTextDocument and QNetworkReply, and, potentially, in user code.

If the function was called with malformed data, for example, an URL that
contained a "charset" parameter that lacked a value (such as
"data:charset,"), and Qt was built with assertions enabled, then it would hit an assertion, resulting in a denial of service
(abort).

This impacts Qt up to 5.15.18, 6.0.0->6.5.8, 6.6.0->6.8.3 and 6.9.0. This has been fixed in 5.15.19, 6.5.9, 6.8.4 and 6.9.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-5455?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qt6-qtbase-common` | AlmaLinux:10 | All versions | 6.8.1-9.el10_0 |
| `qt5-qtbase` | AlmaLinux:9 | All versions | 5.15.9-11.el9_6 |
| `qt5-qtbase-common` | AlmaLinux:9 | All versions | 5.15.9-11.el9_6 |
| `qt5-qtbase-devel` | AlmaLinux:9 | All versions | 5.15.9-11.el9_6 |
| `qt5-qtbase-examples` | AlmaLinux:9 | All versions | 5.15.9-11.el9_6 |
| `qt5-qtbase-gui` | AlmaLinux:9 | All versions | 5.15.9-11.el9_6 |
| `qt5-qtbase-mysql` | AlmaLinux:9 | All versions | 5.15.9-11.el9_6 |
| `qt5-qtbase-odbc` | AlmaLinux:9 | All versions | 5.15.9-11.el9_6 |
| `qt5-qtbase-postgresql` | AlmaLinux:9 | All versions | 5.15.9-11.el9_6 |
| `qt5-qtbase-private-devel` | AlmaLinux:9 | All versions | 5.15.9-11.el9_6 |
| `qt5-qtbase-static` | AlmaLinux:9 | All versions | 5.15.9-11.el9_6 |
| `qt6-qtbase` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-common` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-debuginfo` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-debugsource` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-devel` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-devel-debuginfo` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-examples` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-examples-debuginfo` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-gui` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-gui-debuginfo` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-mysql` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-mysql-debuginfo` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-odbc` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-odbc-debuginfo` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-postgresql` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-postgresql-debuginfo` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-private-devel` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-static` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt6-qtbase-tests-debuginfo` | Red Hat:enterprise_linux:10.0 | All versions | 0:6.8.1-9.el10_0 |
| `qt5-qtbase` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.15.9-11.el9_6 |
| `qt5-qtbase-common` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.15.9-11.el9_6 |
| `qt5-qtbase-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.15.9-11.el9_6 |
| `qt5-qtbase-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.15.9-11.el9_6 |
| `qt5-qtbase-devel` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.15.9-11.el9_6 |
| `qt5-qtbase-devel-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.15.9-11.el9_6 |
| `qt5-qtbase-examples` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.15.9-11.el9_6 |
| `qt5-qtbase-examples-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.15.9-11.el9_6 |
| `qt5-qtbase-gui` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.15.9-11.el9_6 |
| `qt5-qtbase-gui-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.15.9-11.el9_6 |

## How do I fix CVE-2025-5455?

Upgrade to a fixed version.

## Is CVE-2025-5455 being exploited?

There is no known exploitation of CVE-2025-5455 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5455 and fix it if it is affected.

What it is: CVE-2025-5455 is a high-severity denial of service vulnerability in Qt, published on 2 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-5455 in the wild and no public exploit code.

Affected product: Qt. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5455/ (Markdown: https://insights.sbomify.com/CVE-2025-5455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5455
- OSV: https://osv.dev/vulnerability/CVE-2025-5455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5455/
Summaries are generated and may contain mistakes; the official description above is the record.
