CVE-2025-54572 Ruby SAML DOS vulnerability with large SAML response

Medium 6.9 Published Updated

Attackers can cause resource exhaustion and denial of service in applications using the Ruby SAML library by sending large SAML responses.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-54572?

CVE-2025-54572 is a medium-severity denial of service vulnerability in SAML-Toolkits ruby-saml, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Ruby SAML library is for implementing the client side of a SAML authorization. In versions 1.18.0 and below, a denial-of-service vulnerability exists in ruby-saml even with the message_max_bytesize setting configured. The vulnerability occurs because the SAML response is validated for Base64 format prior to checking the message size, leading to potential resource exhaustion. This is fixed in version 1.18.1.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2025-54572?

2 open source packages ship an affected version, including ruby-saml.

PackageAffectedFixed in
ruby-saml RubyGemsAll versions1.18.1
ruby-saml RubyGemsAll versions1.18.1

How do I fix CVE-2025-54572?

Upgrade ruby-saml to 1.18.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-54572 being exploited?

There is no known exploitation of CVE-2025-54572 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2025-54572, DLA-4288-1, GHSA-rrqh-93c8-j966, UBUNTU-CVE-2025-54572.

Is CVE-2025-54572 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free