{"answers":{"affected":"2 open source packages ship an affected version, including ruby-saml.","exploited":"There is no known exploitation of CVE-2025-54572 in the wild and no public exploit code.","fix":"Upgrade ruby-saml to 1.18.1 or later.","what":"CVE-2025-54572 is a medium-severity denial of service vulnerability in SAML-Toolkits ruby-saml, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54572 and fix it if it is affected.\n\nWhat it is: CVE-2025-54572 is a medium-severity denial of service vulnerability in SAML-Toolkits ruby-saml, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54572 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ruby-saml (RubyGems): affected all versions; fixed in 1.18.1\n- ruby-saml (RubyGems): affected all versions; fixed in 1.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54572/ (Markdown: https://insights.sbomify.com/CVE-2025-54572/index.md)","id":"CVE-2025-54572","markdown":"https://insights.sbomify.com/CVE-2025-54572/index.md","name":"CVE-2025-54572","record":{"aliases":["DEBIAN-CVE-2025-54572","DLA-4288-1","GHSA-rrqh-93c8-j966","UBUNTU-CVE-2025-54572"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby SAML library","requires_auth":"none","summary":"Attackers can cause resource exhaustion and denial of service in applications using the Ruby SAML library by sending large SAML responses.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"The Ruby SAML library is for implementing the client side of a SAML authorization. In versions 1.18.0 and below, a denial-of-service vulnerability exists in ruby-saml even with the message_max_bytesize setting configured. The vulnerability occurs because the SAML response is validated for Base64 format prior to checking the message size, leading to potential resource exhaustion. This is fixed in version 1.18.1.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ruby SAML DOS vulnerability with large SAML response","id":"CVE-2025-54572","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"CVAT vulnerable to email verification bypass by use of basic authentication","id":"CVE-2025-54573"},"packages":[{"ecosystem":"RubyGems","fixed":["1.18.1"],"introduced":["0"],"last_affected":[],"package":"ruby-saml","purl":null,"source":"GHSA-rrqh-93c8-j966"},{"ecosystem":"RubyGems","fixed":["1.18.1"],"introduced":["0"],"last_affected":[],"package":"ruby-saml","purl":"pkg:gem/ruby-saml","source":"GHSA-rrqh-93c8-j966"}],"prev":{"headline":"ModSecurity's Insufficient Return Value Handling can Lead to XSS and Source Code Disclosure","id":"CVE-2025-54571"},"products":["ruby-saml"],"published":"2025-07-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["SAML-Toolkits"]},"summary":"Attackers can cause resource exhaustion and denial of service in applications using the Ruby SAML library by sending large SAML responses.","url":"https://insights.sbomify.com/CVE-2025-54572/"}