# CVE-2025-54572: Ruby SAML DOS vulnerability with large SAML response

> Attackers can cause resource exhaustion and denial of service in applications using the Ruby SAML library by sending large SAML responses.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2025
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-54572, DLA-4288-1, GHSA-rrqh-93c8-j966, UBUNTU-CVE-2025-54572

## What is CVE-2025-54572?

CVE-2025-54572 is a medium-severity denial of service vulnerability in SAML-Toolkits ruby-saml, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Ruby SAML library is for implementing the client side of a SAML authorization. In versions 1.18.0 and below, a denial-of-service vulnerability exists in ruby-saml even with the message_max_bytesize setting configured. The vulnerability occurs because the SAML response is validated for Base64 format prior to checking the message size, leading to potential resource exhaustion. This is fixed in version 1.18.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-54572?

2 open source packages ship an affected version, including ruby-saml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby-saml` | RubyGems | All versions | 1.18.1 |
| `ruby-saml` | RubyGems | All versions | 1.18.1 |

## How do I fix CVE-2025-54572?

Upgrade ruby-saml to 1.18.1 or later.

## Is CVE-2025-54572 being exploited?

There is no known exploitation of CVE-2025-54572 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54572 and fix it if it is affected.

What it is: CVE-2025-54572 is a medium-severity denial of service vulnerability in SAML-Toolkits ruby-saml, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54572 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby-saml (RubyGems): affected all versions; fixed in 1.18.1
- ruby-saml (RubyGems): affected all versions; fixed in 1.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54572/ (Markdown: https://insights.sbomify.com/CVE-2025-54572/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54572
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54572
- OSV: https://osv.dev/vulnerability/CVE-2025-54572

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54572/
Summaries are generated and may contain mistakes; the official description above is the record.
