# CVE-2025-54576: OAuth2-Proxy has authentication bypass in oauth2-proxy skip_auth_routes due to Query Parameter inclusion

> Attackers can bypass authentication in OAuth2-Proxy by crafting URLs with query parameters that match skip_auth_routes regex patterns, gaining unauthorized access.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2025
- **Updated:** 30 Jul 2025
- **Also known as:** BIT-oauth2-proxy-2025-54576, GHSA-7rh7-c77v-6434, GO-2025-3833

## What is CVE-2025-54576?

CVE-2025-54576 is a critical authentication bypass vulnerability in oauth2-proxy, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OAuth2-Proxy is an open-source tool that can act as either a standalone reverse proxy or a middleware component integrated into existing reverse proxy or load balancer setups. In versions 7.10.0 and below, oauth2-proxy deployments are vulnerable when using the skip_auth_routes configuration option with regex patterns. Attackers can bypass authentication by crafting URLs with query parameters that satisfy configured regex patterns, allowing unauthorized access to protected resources. The issue stems from skip_auth_routes matching against the full request URI. Deployments using skip_auth_routes with regex patterns containing wildcards or broad matching patterns are most at risk. This issue is fixed in version 7.11.0. Workarounds include: auditing all skip_auth_routes configurations for overly permissive patterns, replacing wildcard patterns with exact path matches where possible, ensuring regex patterns are properly anchored (starting with ^ and ending with $), or implementing custom validation that strips query parameters before regex matching.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2025-54576?

5 open source packages ship an affected version, including github.com/oauth2-proxy/oauth2-proxy/v7, oauth2-proxy and github.com/oauth2-proxy/oauth2-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/oauth2-proxy/oauth2-proxy/v7` | Go | All versions | 7.11.0 |
| `github.com/oauth2-proxy/oauth2-proxy/v7` | Go | All versions | 7.11.0 |
| `github.com/oauth2-proxy/oauth2-proxy/v7` | Go | All versions | 7.11.0 |
| `oauth2-proxy` | Bitnami | All versions | 7.11.0 |
| `github.com/oauth2-proxy/oauth2-proxy` | Go | All versions | None |

Products: Oauth2 Proxy Project Oauth2 Proxy.

## How do I fix CVE-2025-54576?

Upgrade github.com/oauth2-proxy/oauth2-proxy/v7 to 7.11.0 or later.

## Is CVE-2025-54576 being exploited?

There is no known exploitation of CVE-2025-54576 in the wild and no public exploit code.

## Other vulnerabilities in oauth2-proxy

- [CVE-2026-40575](https://insights.sbomify.com/CVE-2026-40575/): OAuth2 Proxy has an Authentication Bypass via X-Forwarded-Uri Header Spoofing (critical 9.1)
- [CVE-2026-34457](https://insights.sbomify.com/CVE-2026-34457/): OAuth2 Proxy: Health Check User-Agent Matching Bypasses Authentication in auth_request Mode (critical 9.1)
- [CVE-2017-1000069](https://insights.sbomify.com/CVE-2017-1000069/): Cross-site Request Forgery (CSRF) (high 8.8)
- [CVE-2026-41059](https://insights.sbomify.com/CVE-2026-41059/): OAuth2 Proxy has an Authentication Bypass via Fragment Confusion in skip_auth_routes and skip_auth_regex (high 8.2)
- [CVE-2020-11053](https://insights.sbomify.com/CVE-2020-11053/): Open Redirect in OAuth2 Proxy (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54576 and fix it if it is affected.

What it is: CVE-2025-54576 is a critical authentication bypass vulnerability in oauth2-proxy, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54576 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected all versions; fixed in 7.11.0
- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected all versions; fixed in 7.11.0
- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected all versions; fixed in 7.11.0
- oauth2-proxy (Bitnami): affected all versions; fixed in 7.11.0
- github.com/oauth2-proxy/oauth2-proxy (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54576/ (Markdown: https://insights.sbomify.com/CVE-2025-54576/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54576
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54576
- OSV: https://osv.dev/vulnerability/CVE-2025-54576

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54576/
Summaries are generated and may contain mistakes; the official description above is the record.
