{"answers":{"affected":"2 open source packages ship an affected version, including vproxy.","exploited":"There is no known exploitation of CVE-2025-54581 in the wild and no public exploit code.","fix":"Upgrade vproxy to 2.4.0 or later.","what":"CVE-2025-54581 is a high-severity denial of service vulnerability in 0x676e67 vproxy, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54581 and fix it if it is affected.\n\nWhat it is: CVE-2025-54581 is a high-severity denial of service vulnerability in 0x676e67 vproxy, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54581 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vproxy (crates.io): affected all versions; fixed in 2.4.0\n- vproxy (crates.io): affected all versions; fixed in 2.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54581/ (Markdown: https://insights.sbomify.com/CVE-2025-54581/index.md)","id":"CVE-2025-54581","markdown":"https://insights.sbomify.com/CVE-2025-54581/index.md","name":"CVE-2025-54581","record":{"aliases":["GHSA-7h24-c332-p48c"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"HTTP proxy server","requires_auth":"none","summary":"An attacker can crash the vproxy server by sending a crafted HTTP Proxy-Authorization header with a zero TTL value, causing a division by zero panic.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-369","name":"Divide By Zero"}],"description":"vproxy is an HTTP/HTTPS/SOCKS5 proxy server. In versions 2.3.3 and below, untrusted data is extracted from the user-controlled HTTP Proxy-Authorization header and passed to Extension::try_from and flows into parse_ttl_extension where it is parsed as a TTL value. If an attacker supplies a TTL of zero (e.g. by using a username such as 'configuredUser-ttl-0'), the modulo operation 'timestamp % ttl' will cause a division by zero panic, causing the server to crash causing a denial-of-service. This is fixed in version 2.4.0.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vproxy is vulnerable to a divide by zero DoS attack","id":"CVE-2025-54581","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Reason: This candidate was issued in error.","id":"CVE-2025-54582"},"packages":[{"ecosystem":"crates.io","fixed":["2.4.0"],"introduced":["0"],"last_affected":[],"package":"vproxy","purl":null,"source":"GHSA-7h24-c332-p48c"},{"ecosystem":"crates.io","fixed":["2.4.0"],"introduced":["0"],"last_affected":[],"package":"vproxy","purl":"pkg:cargo/vproxy","source":"GHSA-7h24-c332-p48c"}],"prev":{"headline":"OAuth2-Proxy has authentication bypass in oauth2-proxy skip_auth_routes due to Query Parameter inclusion","id":"CVE-2025-54576"},"products":["vproxy"],"published":"2025-07-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-30","vendors":["0x676e67"]},"summary":"An attacker can crash the vproxy server by sending a crafted HTTP Proxy-Authorization header with a zero TTL value, causing a division by zero panic.","url":"https://insights.sbomify.com/CVE-2025-54581/"}