# CVE-2025-54581: vproxy is vulnerable to a divide by zero DoS attack

> An attacker can crash the vproxy server by sending a crafted HTTP Proxy-Authorization header with a zero TTL value, causing a division by zero panic.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2025
- **Updated:** 30 Jul 2025
- **Also known as:** GHSA-7h24-c332-p48c

## What is CVE-2025-54581?

CVE-2025-54581 is a high-severity denial of service vulnerability in 0x676e67 vproxy, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vproxy is an HTTP/HTTPS/SOCKS5 proxy server. In versions 2.3.3 and below, untrusted data is extracted from the user-controlled HTTP Proxy-Authorization header and passed to Extension::try_from and flows into parse_ttl_extension where it is parsed as a TTL value. If an attacker supplies a TTL of zero (e.g. by using a username such as 'configuredUser-ttl-0'), the modulo operation 'timestamp % ttl' will cause a division by zero panic, causing the server to crash causing a denial-of-service. This is fixed in version 2.4.0.

Weakness: CWE-369 (Divide By Zero)

## Which versions are affected by CVE-2025-54581?

2 open source packages ship an affected version, including vproxy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vproxy` | crates.io | All versions | 2.4.0 |
| `vproxy` | crates.io | All versions | 2.4.0 |

## How do I fix CVE-2025-54581?

Upgrade vproxy to 2.4.0 or later.

## Is CVE-2025-54581 being exploited?

There is no known exploitation of CVE-2025-54581 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54581 and fix it if it is affected.

What it is: CVE-2025-54581 is a high-severity denial of service vulnerability in 0x676e67 vproxy, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54581 in the wild and no public exploit code.

Affected packages and fixed versions:
- vproxy (crates.io): affected all versions; fixed in 2.4.0
- vproxy (crates.io): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54581/ (Markdown: https://insights.sbomify.com/CVE-2025-54581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54581
- OSV: https://osv.dev/vulnerability/CVE-2025-54581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54581/
Summaries are generated and may contain mistakes; the official description above is the record.
