# CVE-2025-54583: GitProxy bypasses approvals when pushing multiple branches

> Attackers can bypass approval policies and push unauthorized code or secrets to repositories by pushing multiple branches simultaneously.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2025
- **Updated:** 30 Jul 2025
- **Also known as:** GHSA-qr93-8wwf-22g4

## What is CVE-2025-54583?

CVE-2025-54583 is a high-severity vulnerability in finos git-proxy, published on 30 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitProxy is an application that stands between developers and a Git remote endpoint (e.g., github.com). Versions 1.19.1 and below allow users to push to remote repositories while bypassing policies and explicit approvals. Since checks and plugins are skipped, code containing secrets or unwanted changes could be pushed into a repository. This is fixed in version 1.19.2.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-54583?

2 open source packages ship an affected version, including @finos/git-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@finos/git-proxy` | npm | All versions | 1.19.2 |
| `@finos/git-proxy` | npm | All versions | 1.19.2 |

Products: Finos Gitproxy.

## How do I fix CVE-2025-54583?

Upgrade @finos/git-proxy to 1.19.2 or later.

## Is CVE-2025-54583 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54583 exists.

## Other vulnerabilities in finos git-proxy

- [CVE-2025-54585](https://insights.sbomify.com/CVE-2025-54585/): GitProxy is vulnerable to a new branch approval exploit (high 8.2)
- [CVE-2025-54586](https://insights.sbomify.com/CVE-2025-54586/): GitProxy is susceptible to a hidden commits injection attack (high 7.1)
- [CVE-2025-54584](https://insights.sbomify.com/CVE-2025-54584/): GitProxy is vulnerable to a packfile parsing exploit (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54583 and fix it if it is affected.

What it is: CVE-2025-54583 is a high-severity vulnerability in finos git-proxy, published on 30 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54583 exists.

Affected packages and fixed versions:
- @finos/git-proxy (npm): affected all versions; fixed in 1.19.2
- @finos/git-proxy (npm): affected all versions; fixed in 1.19.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54583/ (Markdown: https://insights.sbomify.com/CVE-2025-54583/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54583
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54583
- OSV: https://osv.dev/vulnerability/CVE-2025-54583

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54583/
Summaries are generated and may contain mistakes; the official description above is the record.
