# CVE-2025-54585: GitProxy is vulnerable to a new branch approval exploit

> Attackers can bypass commit approval policies on parent branches when creating new branches in GitProxy, allowing unapproved code changes.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jul 2025
- **Updated:** 30 Jul 2025
- **Also known as:** GHSA-39p2-8hq9-fwj6

## What is CVE-2025-54585?

CVE-2025-54585 is a high-severity missing authorization vulnerability in finos git-proxy, published on 30 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

GitProxy is an application that stands between developers and a Git remote endpoint. In versions 1.19.1 and below, attackers can exploit the way GitProxy handles new branch creation to bypass the approval of prior commits on the parent branch. The vulnerability impacts all users or organizations relying on GitProxy to enforce policy and prevent unapproved changes. It requires no elevated privileges beyond regular push access, and no extra user interaction. It does however, require a GitProxy administrator or designated user (canUserApproveRejectPush) to approve pushes to the child branch. This is fixed in version 1.19.2.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-54585?

2 open source packages ship an affected version, including @finos/git-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@finos/git-proxy` | npm | All versions | 1.19.2 |
| `@finos/git-proxy` | npm | All versions | 1.19.2 |

Products: Finos Gitproxy.

## How do I fix CVE-2025-54585?

Upgrade @finos/git-proxy to 1.19.2 or later.

## Is CVE-2025-54585 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54585 exists.

## Other vulnerabilities in finos git-proxy

- [CVE-2025-54583](https://insights.sbomify.com/CVE-2025-54583/): GitProxy bypasses approvals when pushing multiple branches (high 8.3)
- [CVE-2025-54586](https://insights.sbomify.com/CVE-2025-54586/): GitProxy is susceptible to a hidden commits injection attack (high 7.1)
- [CVE-2025-54584](https://insights.sbomify.com/CVE-2025-54584/): GitProxy is vulnerable to a packfile parsing exploit (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54585 and fix it if it is affected.

What it is: CVE-2025-54585 is a high-severity missing authorization vulnerability in finos git-proxy, published on 30 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54585 exists.

Affected packages and fixed versions:
- @finos/git-proxy (npm): affected all versions; fixed in 1.19.2
- @finos/git-proxy (npm): affected all versions; fixed in 1.19.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54585/ (Markdown: https://insights.sbomify.com/CVE-2025-54585/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54585
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54585
- OSV: https://osv.dev/vulnerability/CVE-2025-54585

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54585/
Summaries are generated and may contain mistakes; the official description above is the record.
