CVE-2025-54588 Envoy: Race condition in Dynamic Forward Proxy leads to use-after-free and segmentation faults
A race condition in Envoy's Dynamic Forward Proxy causes use-after-free and crashes, requiring specific runtime flags and header modifications to exploit.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-54588?
CVE-2025-54588 is a high-severity use after free vulnerability in Envoyproxy Envoy, published on 2 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Envoy is an open source L7 proxy and communication bus designed for large modern service oriented architectures. Versions 1.34.0 through 1.34.4 and 1.35.0 contain a use-after-free (UAF) vulnerability in the DNS cache, causing abnormal process termination. The vulnerability is in Envoy's Dynamic Forward Proxy implementation, occurring when a completion callback for a DNS resolution triggers new DNS resolutions or removes existing pending resolutions. This condition may occur when the following conditions are met: dynamic Forwarding Filter is enabled, the `envoy.reloadable_features.dfp_cluster_resolves_hosts` runtime flag is enabled, and the Host header is modified between the Dynamic Forwarding Filter and Router filters. This issue is resolved in versions 1.34.5 and 1.35.1. To work around this issue, set the envoy.reloadable_features.dfp_cluster_resolves_hosts runtime flag to false.
Weakness: CWE-416
Which versions are affected by CVE-2025-54588?
5 open source packages ship an affected version, including github.com/envoyproxy/envoy and envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/envoyproxy/envoy Go | From 1.34.0 | 1.34.5 |
github.com/envoyproxy/envoy Go | From 1.34.0 | 1.34.5 |
github.com/envoyproxy/envoy Go | From 1.35.0 | 1.35.1 |
github.com/envoyproxy/envoy Go | From 1.35.0 | 1.35.1 |
envoy Bitnami | From 1.34.0 | 1.34.5, 1.35.1 |
Products include Envoyproxy Envoy.
How do I fix CVE-2025-54588?
Upgrade github.com/envoyproxy/envoy to a fixed version for your release line: 1.34.5 or 1.35.1.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2025-54588 being exploited?
There is no known exploitation of CVE-2025-54588 in the wild and no public exploit code.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2025-54588, GHSA-g9vw-6pvx-7gmw.