# CVE-2025-54588: Envoy: Race condition in Dynamic Forward Proxy leads to use-after-free and segmentation faults

> A race condition in Envoy's Dynamic Forward Proxy causes use-after-free and crashes, requiring specific runtime flags and header modifications to exploit.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2025
- **Updated:** 3 Sep 2025
- **Also known as:** BIT-envoy-2025-54588, GHSA-g9vw-6pvx-7gmw

## What is CVE-2025-54588?

CVE-2025-54588 is a high-severity use after free vulnerability in Envoyproxy Envoy, published on 2 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is an open source L7 proxy and communication bus designed for large modern service oriented architectures. Versions 1.34.0 through 1.34.4 and 1.35.0 contain a use-after-free (UAF) vulnerability in the DNS cache, causing abnormal process termination. The vulnerability is in Envoy's Dynamic Forward Proxy implementation, occurring when a completion callback for a DNS resolution triggers new DNS resolutions or removes existing pending resolutions. This condition may occur when the following conditions are met: dynamic Forwarding Filter is enabled, the `envoy.reloadable_features.dfp_cluster_resolves_hosts` runtime flag is enabled, and the Host header is modified between the Dynamic Forwarding Filter and Router filters. This issue is resolved in versions 1.34.5 and 1.35.1. To work around this issue, set the envoy.reloadable_features.dfp_cluster_resolves_hosts runtime flag to false.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2025-54588?

5 open source packages ship an affected version, including github.com/envoyproxy/envoy and envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/envoy` | Go | From 1.34.0 | 1.34.5 |
| `github.com/envoyproxy/envoy` | Go | From 1.34.0 | 1.34.5 |
| `github.com/envoyproxy/envoy` | Go | From 1.35.0 | 1.35.1 |
| `github.com/envoyproxy/envoy` | Go | From 1.35.0 | 1.35.1 |
| `envoy` | Bitnami | From 1.34.0 | 1.34.5, 1.35.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2025-54588?

Upgrade github.com/envoyproxy/envoy to a fixed version for your release line: 1.34.5 or 1.35.1.

## Is CVE-2025-54588 being exploited?

There is no known exploitation of CVE-2025-54588 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54588 and fix it if it is affected.

What it is: CVE-2025-54588 is a high-severity use after free vulnerability in Envoyproxy Envoy, published on 2 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54588 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/envoyproxy/envoy (Go): affected from 1.34.0; fixed in 1.34.5
- github.com/envoyproxy/envoy (Go): affected from 1.34.0; fixed in 1.34.5
- github.com/envoyproxy/envoy (Go): affected from 1.35.0; fixed in 1.35.1
- github.com/envoyproxy/envoy (Go): affected from 1.35.0; fixed in 1.35.1
- envoy (Bitnami): affected from 1.34.0; fixed in 1.34.5, 1.35.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54588/ (Markdown: https://insights.sbomify.com/CVE-2025-54588/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54588
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54588
- OSV: https://osv.dev/vulnerability/CVE-2025-54588

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54588/
Summaries are generated and may contain mistakes; the official description above is the record.
