# CVE-2025-54589: copyparty Reflected XSS via Filter Parameter

> Attackers can execute arbitrary scripts in victim browsers via the filter parameter on the recent uploads page, affecting both authenticated and unauthenticated users.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Jul 2025
- **Updated:** 31 Jul 2025
- **Also known as:** GHSA-8mx2-rjh8-q3jq, PYSEC-2026-1276

## What is CVE-2025-54589?

CVE-2025-54589 is a medium-severity cross-site scripting vulnerability in 9001 copyparty, published on 31 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Copyparty is a portable file server. In versions 1.18.6 and below, when accessing the recent uploads page at `/?ru`, users can filter the results using an input field at the top. This field appends a filter parameter to the URL, which reflects its value directly into a `<script>` block without proper escaping, allowing for reflected Cross-Site Scripting (XSS) and can be exploited against both authenticated and unauthenticated users. This is fixed in version 1.18.7.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-54589?

3 open source packages ship an affected version, including copyparty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `copyparty` | PyPI | All versions | 1.18.7 |
| `copyparty` | PyPI | All versions | 1.18.7 |
| `copyparty` | PyPI | All versions | 1.18.7 |

Products: 9001 Copyparty.

## How do I fix CVE-2025-54589?

Upgrade copyparty to 1.18.7 or later.

## Is CVE-2025-54589 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54589 exists.

Public exploit code:

- PoC for CVE-2025-54589 – a reflected XSS vulnerability in Copyparty ≤ 1.18.6. (github_poc): https://github.com/byteReaper77/CVE-2025-54589
- Copyparty 1.18.6 - Reflected Cross-Site Scripting (XSS) (exploitdb)
- Copyparty <=1.18.6 - Cross-Site Scripting (nuclei): http/cves/2025/CVE-2025-54589.yaml

## Other vulnerabilities in 9001 copyparty

- [CVE-2023-41471](https://insights.sbomify.com/CVE-2023-41471/): Cross-site scripting in n/a (high 7.8)
- [CVE-2025-54796](https://insights.sbomify.com/CVE-2025-54796/): Copyparty is vulnerable to Regex Denial of Service (ReDoS) attacks through "Recent Uploads" page (high 7.5)
- [CVE-2023-37474](https://insights.sbomify.com/CVE-2023-37474/): Path traversal in copyparty (high 7.5)
- [CVE-2023-38501](https://insights.sbomify.com/CVE-2023-38501/): copyparty vulnerable to reflected cross-site scripting via k304 parameter (medium 6.3)
- [CVE-2026-27948](https://insights.sbomify.com/CVE-2026-27948/): Copyparty vulnerable to eflected cross-site scripting via setck parameter (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54589 and fix it if it is affected.

What it is: CVE-2025-54589 is a medium-severity cross-site scripting vulnerability in 9001 copyparty, published on 31 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54589 exists.

Affected packages and fixed versions:
- copyparty (PyPI): affected all versions; fixed in 1.18.7
- copyparty (PyPI): affected all versions; fixed in 1.18.7
- copyparty (PyPI): affected all versions; fixed in 1.18.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54589/ (Markdown: https://insights.sbomify.com/CVE-2025-54589/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54589
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54589
- OSV: https://osv.dev/vulnerability/CVE-2025-54589

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54589/
Summaries are generated and may contain mistakes; the official description above is the record.
