CVE-2025-5459 OS Command Injection

High 8.6 Published Updated

Attackers with node group editing permissions can execute arbitrary commands as root via crafted class parameters in Puppet Enterprise.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-5459?

CVE-2025-5459 is a high-severity command injection vulnerability in Puppet Puppet Enterprise, published on 26 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A user with specific node group editing permissions and a specially crafted class parameter could be used to execute commands as root on the primary host. It affects Puppet Enterprise versions 2018.1.8 through 2023.8.3 and 2025.3 and has been resolved in versions 2023.8.4 and 2025.4.0.

Weakness: CWE-78

Which versions are affected by CVE-2025-5459?

It affects 1 product.

Products include Puppet Puppet Enterprise.

How do I fix CVE-2025-5459?

No fix has been published for CVE-2025-5459 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-5459 being exploited?

There is no known exploitation of CVE-2025-5459 in the wild and no public exploit code.

All Puppet Puppet Enterprise vulnerabilities

Sources

Also known as GHSA-2q8m-2xcf-6rrj.

Is CVE-2025-5459 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free