# CVE-2025-5459: OS Command Injection

> Attackers with node group editing permissions can execute arbitrary commands as root via crafted class parameters in Puppet Enterprise.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Jun 2025
- **Updated:** 4 Sep 2026
- **Also known as:** GHSA-2q8m-2xcf-6rrj

## What is CVE-2025-5459?

CVE-2025-5459 is a high-severity command injection vulnerability in Puppet Puppet Enterprise, published on 26 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A user with specific node group editing permissions and a specially crafted class parameter could be used to execute commands as root on the primary host. It affects Puppet Enterprise versions 2018.1.8 through 2023.8.3 and 2025.3 and has been resolved in versions 2023.8.4 and 2025.4.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-5459?

It affects 1 product.


Products: Puppet Puppet Enterprise.

## How do I fix CVE-2025-5459?

No fix has been published for CVE-2025-5459 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-5459 being exploited?

There is no known exploitation of CVE-2025-5459 in the wild and no public exploit code.

## Other vulnerabilities in Puppet Puppet Enterprise

- [CVE-2023-2530](https://insights.sbomify.com/CVE-2023-2530/): Privilege escalation in Puppet Enterprise (critical 9.8)
- [CVE-2019-10694](https://insights.sbomify.com/CVE-2019-10694/): Hardcoded credentials in Puppet Enterprise (critical 9.8)
- [CVE-2018-11749](https://insights.sbomify.com/CVE-2018-11749/): Information disclosure in Puppet Enterprise (critical 9.8)
- [CVE-2021-27020](https://insights.sbomify.com/CVE-2021-27020/): Other in Puppet Enterprise (high 8.8)
- [CVE-2015-5686](https://insights.sbomify.com/CVE-2015-5686/): Cross-site request forgery in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5459 and fix it if it is affected.

What it is: CVE-2025-5459 is a high-severity command injection vulnerability in Puppet Puppet Enterprise, published on 26 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-5459 in the wild and no public exploit code.

Affected product: Puppet Puppet Enterprise. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5459/ (Markdown: https://insights.sbomify.com/CVE-2025-5459/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5459
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5459
- OSV: https://osv.dev/vulnerability/CVE-2025-5459

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5459/
Summaries are generated and may contain mistakes; the official description above is the record.
