# CVE-2025-54590: webfinger.js is vulnerable to Blind SSRF attacks through localhost

> Attackers can exploit insufficient localhost validation in webfinger.js to perform blind SSRF attacks, accessing internal services on the host or local network.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2025
- **Updated:** 1 Aug 2025
- **Also known as:** GHSA-8xq3-w9fx-74rv

## What is CVE-2025-54590?

CVE-2025-54590 is a medium-severity server-side request forgery vulnerability in silverbucket webfinger.js, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

webfinger.js is a TypeScript-based WebFinger client that runs in both browsers and Node.js environments. In versions 2.8.0 and below, the lookup function accepts user addresses for account checking. However, the ActivityPub specification requires preventing access to localhost services in production. This library does not prevent localhost access, only checking for hosts that start with "localhost" and end with a port. Users can exploit this by creating servers that send GET requests with controlled host, path, and port parameters to query services on the instance's host or local network, enabling blind SSRF attacks. This is fixed in version 2.8.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-54590?

2 open source packages ship an affected version, including webfinger.js.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `webfinger.js` | npm | All versions | 2.8.1 |
| `webfinger.js` | npm | All versions | 2.8.1 |

## How do I fix CVE-2025-54590?

Upgrade webfinger.js to 2.8.1 or later.

## Is CVE-2025-54590 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54590 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54590 and fix it if it is affected.

What it is: CVE-2025-54590 is a medium-severity server-side request forgery vulnerability in silverbucket webfinger.js, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54590 exists.

Affected packages and fixed versions:
- webfinger.js (npm): affected all versions; fixed in 2.8.1
- webfinger.js (npm): affected all versions; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54590/ (Markdown: https://insights.sbomify.com/CVE-2025-54590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54590
- OSV: https://osv.dev/vulnerability/CVE-2025-54590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54590/
Summaries are generated and may contain mistakes; the official description above is the record.
