CVE-2025-5472 Denial of Service via Uncontrolled Recursive JSON Parsing in JSONReader in run-llama/llama_index

Medium 6.5 Published Updated

Attackers can crash applications using the llama_index JSONReader by submitting deeply nested JSON, causing a stack overflow and denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-5472?

CVE-2025-5472 is a medium-severity denial of service vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.

Weakness: CWE-674

Which versions are affected by CVE-2025-5472?

4 open source packages ship an affected version, including llama-index-core and llama-index. It affects 1 product.

PackageAffectedFixed in
llama-index-core PyPIAll versions0.12.38
llama-index-core PyPIAll versions0.12.38
llama-index-core PyPIAll versions0.12.38
llama-index PyPIFrom 0.12.280.12.38

Products include Llamaindex Llamaindex.

How do I fix CVE-2025-5472?

Upgrade llama-index-core to 0.12.38 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-5472 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5472 exists.

Sources

Also known as GHSA-3wxx-q3gv-pvvv, PYSEC-2025-251, PYSEC-2026-1559.

Is CVE-2025-5472 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free