{"answers":{"affected":"4 open source packages ship an affected version, including llama-index-core and llama-index. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5472 exists.","fix":"Upgrade llama-index-core to 0.12.38 or later.","what":"CVE-2025-5472 is a medium-severity denial of service vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-5472 and fix it if it is affected.\n\nWhat it is: CVE-2025-5472 is a medium-severity denial of service vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5472 exists.\n\nAffected packages and fixed versions:\n- llama-index-core (PyPI): affected all versions; fixed in 0.12.38\n- llama-index-core (PyPI): affected all versions; fixed in 0.12.38\n- llama-index-core (PyPI): affected all versions; fixed in 0.12.38\n- llama-index (PyPI): affected from 0.12.28; fixed in 0.12.38\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5472/ (Markdown: https://insights.sbomify.com/CVE-2025-5472/index.md)","id":"CVE-2025-5472","markdown":"https://insights.sbomify.com/CVE-2025-5472/index.md","name":"CVE-2025-5472","record":{"aliases":["GHSA-3wxx-q3gv-pvvv","PYSEC-2025-251","PYSEC-2026-1559"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python LLM library","requires_auth":"none","summary":"Attackers can crash applications using the llama_index JSONReader by submitting deeply nested JSON, causing a stack overflow and denial of service.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"llamaindex","vendor":"llamaindex"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of Service via Uncontrolled Recursive JSON Parsing in JSONReader in run-llama/llama_index","id":"CVE-2025-5472","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"GIMP ICO File Parsing Integer Overflow Remote Code Execution Vulnerability","id":"CVE-2025-5473"},"packages":[{"ecosystem":"PyPI","fixed":["0.12.38"],"introduced":["0.12.28"],"last_affected":[],"package":"llama-index","purl":"pkg:pypi/llama-index","source":"PYSEC-2025-251"},{"ecosystem":"PyPI","fixed":["0.12.38"],"introduced":["0"],"last_affected":[],"package":"llama-index-core","purl":null,"source":"GHSA-3wxx-q3gv-pvvv"},{"ecosystem":"PyPI","fixed":["0.12.38"],"introduced":["0"],"last_affected":[],"package":"llama-index-core","purl":"pkg:pypi/llama-index-core","source":"GHSA-3wxx-q3gv-pvvv"},{"ecosystem":"PyPI","fixed":["0.12.38"],"introduced":["0"],"last_affected":[],"package":"llama-index-core","purl":"pkg:pypi/llama-index-core","source":"PYSEC-2026-1559"}],"prev":{"headline":"Dylib Hijacking in Yandex Telemost","id":"CVE-2025-5471"},"products":["run-llama/llama_index"],"published":"2025-07-07","related":[{"cvss_score":10,"headline":"SQL Injection to RCE in run-llama/llama_index","id":"CVE-2024-12909","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.8,"headline":"SQL Injection in run-llama/llama_index","id":"CVE-2025-1793","kev_date_added":null,"published":"2025-06-05"},{"cvss_score":9.8,"headline":"SQL Injection in run-llama/llama_index","id":"CVE-2025-1750","kev_date_added":null,"published":"2025-06-02"},{"cvss_score":9.8,"headline":"SQL Injection in run-llama/llama_index","id":"CVE-2024-11958","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.8,"headline":"Command Injection in run-llama/llama_index","id":"CVE-2024-3271","kev_date_added":null,"published":"2024-04-16"},{"cvss_score":9.8,"headline":"SQL injection in llama-index","id":"CVE-2024-23751","kev_date_added":null,"published":"2024-01-22"},{"cvss_score":8.8,"headline":"LlamaIndex includes an exec call for `import {cls_name}`","id":"CVE-2024-45201","kev_date_added":null,"published":"2024-08-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-07","vendors":["run-llama"]},"summary":"Attackers can crash applications using the llama_index JSONReader by submitting deeply nested JSON, causing a stack overflow and denial of service.","url":"https://insights.sbomify.com/CVE-2025-5472/"}