# CVE-2025-5472: Denial of Service via Uncontrolled Recursive JSON Parsing in JSONReader in run-llama/llama_index

> Attackers can crash applications using the llama_index JSONReader by submitting deeply nested JSON, causing a stack overflow and denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jul 2025
- **Updated:** 7 Jul 2025
- **Also known as:** GHSA-3wxx-q3gv-pvvv, PYSEC-2025-251, PYSEC-2026-1559

## What is CVE-2025-5472?

CVE-2025-5472 is a medium-severity denial of service vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2025-5472?

4 open source packages ship an affected version, including llama-index-core and llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-core` | PyPI | All versions | 0.12.38 |
| `llama-index-core` | PyPI | All versions | 0.12.38 |
| `llama-index-core` | PyPI | All versions | 0.12.38 |
| `llama-index` | PyPI | From 0.12.28 | 0.12.38 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2025-5472?

Upgrade llama-index-core to 0.12.38 or later.

## Is CVE-2025-5472 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5472 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5472 and fix it if it is affected.

What it is: CVE-2025-5472 is a medium-severity denial of service vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5472 exists.

Affected packages and fixed versions:
- llama-index-core (PyPI): affected all versions; fixed in 0.12.38
- llama-index-core (PyPI): affected all versions; fixed in 0.12.38
- llama-index-core (PyPI): affected all versions; fixed in 0.12.38
- llama-index (PyPI): affected from 0.12.28; fixed in 0.12.38

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5472/ (Markdown: https://insights.sbomify.com/CVE-2025-5472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5472
- OSV: https://osv.dev/vulnerability/CVE-2025-5472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5472/
Summaries are generated and may contain mistakes; the official description above is the record.
