# CVE-2025-54780: glpi-screenshot-plugin exposes local files in /ajax/screenshot.php


- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 5 Aug 2025
- **Updated:** 5 Aug 2025
- **Also known as:** GHSA-x6mp-jhxw-9xrp

## What is CVE-2025-54780?

CVE-2025-54780 is a high-severity vulnerability in cconard96 glpi-screenshot-plugin, published on 5 Aug 2025. 

### Official description

The glpi-screenshot-plugin allows users to take screenshots or screens recording directly from GLPI. In versions below 2.0.2, authenticated user can use the /ajax/screenshot.php endpoint to leak files from the system or use PHP wrappers. This is fixed in version 2.0.2.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2025-54780?


## How do I fix CVE-2025-54780?

No fix has been published for CVE-2025-54780 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54780 being exploited?

There is no known exploitation of CVE-2025-54780 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54780 and fix it if it is affected.

What it is: CVE-2025-54780 is a high-severity vulnerability in cconard96 glpi-screenshot-plugin, published on 5 Aug 2025. 
Exploitation: There is no known exploitation of CVE-2025-54780 in the wild and no public exploit code.

Affected product: cconard96 glpi-screenshot-plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54780/ (Markdown: https://insights.sbomify.com/CVE-2025-54780/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54780
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54780
- OSV: https://osv.dev/vulnerability/CVE-2025-54780

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54780/
Summaries are generated and may contain mistakes; the official description above is the record.
