CVE-2025-54784 SuiteCRM is vulnerable to Cross Site Scripting (XSS) through its email viewer
An attacker can execute arbitrary scripts in the email viewer, allowing data extraction or account takeover for logged-in users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2025-54784?
CVE-2025-54784 is a high-severity cross-site scripting vulnerability in Salesagility Suitecrm, published on 7 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. There is a Cross Site Scripting (XSS) vulnerability in the email viewer in versions 7.14.0 through 7.14.6. An external attacker could send a prepared message to the inbox of the SuiteCRM-instance. By simply viewing emails as the logged-in user, the payload can be triggered. With that, an attacker is able to run arbitrary actions as the logged-in user - like extracting data, or if it is an admin executing the payload, takeover the instance. This is fixed in versions 7.14.7.
Weakness: CWE-79
Which versions are affected by CVE-2025-54784?
It affects 1 product.
Products include Salesagility Suitecrm.
How do I fix CVE-2025-54784?
No fix has been published for CVE-2025-54784 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-54784 being exploited?
There is no known exploitation of CVE-2025-54784 in the wild and no public exploit code.
Other vulnerabilities in Salesagility Suitecrm
Sources
Also known as GHSA-vg8q-xcq5-mh3p.