# CVE-2025-54796: Copyparty is vulnerable to Regex Denial of Service (ReDoS) attacks through "Recent Uploads" page

> An attacker can cause a denial of service in Copyparty by submitting malicious regex filters to the Recent Uploads page.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2025
- **Updated:** 4 Aug 2025
- **Also known as:** GHSA-5662-2rj7-f2v6, PYSEC-2026-1275

## What is CVE-2025-54796?

CVE-2025-54796 is a high-severity denial of service vulnerability in 9001 copyparty, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Copyparty is a portable file server. Versions prior to 1.18.9, the filter parameter for the "Recent Uploads" page allows arbitrary RegExes. If this feature is enabled (which is the default), an attacker can craft a filter which deadlocks the server. This is fixed in version 1.18.9.

Weakness: CWE-833 (Deadlock), CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-54796?

3 open source packages ship an affected version, including copyparty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `copyparty` | PyPI | All versions | 1.18.9 |
| `copyparty` | PyPI | All versions | 1.18.9 |
| `copyparty` | PyPI | All versions | 1.18.9 |

Products: 9001 Copyparty.

## How do I fix CVE-2025-54796?

Upgrade copyparty to 1.18.9 or later.

## Is CVE-2025-54796 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54796 exists.

## Other vulnerabilities in 9001 copyparty

- [CVE-2023-41471](https://insights.sbomify.com/CVE-2023-41471/): Cross-site scripting in n/a (high 7.8)
- [CVE-2023-37474](https://insights.sbomify.com/CVE-2023-37474/): Path traversal in copyparty (high 7.5)
- [CVE-2025-54589](https://insights.sbomify.com/CVE-2025-54589/): copyparty Reflected XSS via Filter Parameter (medium 6.3)
- [CVE-2023-38501](https://insights.sbomify.com/CVE-2023-38501/): copyparty vulnerable to reflected cross-site scripting via k304 parameter (medium 6.3)
- [CVE-2026-27948](https://insights.sbomify.com/CVE-2026-27948/): Copyparty vulnerable to eflected cross-site scripting via setck parameter (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54796 and fix it if it is affected.

What it is: CVE-2025-54796 is a high-severity denial of service vulnerability in 9001 copyparty, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54796 exists.

Affected packages and fixed versions:
- copyparty (PyPI): affected all versions; fixed in 1.18.9
- copyparty (PyPI): affected all versions; fixed in 1.18.9
- copyparty (PyPI): affected all versions; fixed in 1.18.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54796/ (Markdown: https://insights.sbomify.com/CVE-2025-54796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54796
- OSV: https://osv.dev/vulnerability/CVE-2025-54796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54796/
Summaries are generated and may contain mistakes; the official description above is the record.
