# CVE-2025-54801: Fiber Susceptible to Crash via `BodyParser` Due to Unvalidated Large Slice Index in Decoder

> Attackers can crash Fiber web applications by sending form data with excessively large numeric keys, causing memory exhaustion or panics.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2025
- **Updated:** 7 Aug 2025
- **Also known as:** GHSA-qx2q-88mx-vhg7, GO-2025-3845

## What is CVE-2025-54801?

CVE-2025-54801 is a high-severity denial of service vulnerability in gofiber fiber, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fiber is an Express inspired web framework written in Go. In versions 2.52.8 and below, when using Fiber's Ctx.BodyParser to parse form data containing a large numeric key that represents a slice index (e.g., test.18446744073704), the application crashes due to an out-of-bounds slice allocation in the underlying schema decoder. The root cause is that the decoder attempts to allocate a slice of length idx + 1 without validating whether the index is within a safe or reasonable range. If the idx is excessively large, this leads to an integer overflow or memory exhaustion, causing a panic or crash. This is fixed in version 2.52.9.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2025-54801?

3 open source packages ship an affected version, including github.com/gofiber/fiber/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.52.9 |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.52.9 |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.52.9 |

Products: Gofiber Fiber.

## How do I fix CVE-2025-54801?

Upgrade github.com/gofiber/fiber/v2 to 2.52.9 or later.

## Is CVE-2025-54801 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54801 exists.

## Other vulnerabilities in gofiber fiber

- [CVE-2024-38513](https://insights.sbomify.com/CVE-2024-38513/): Fiber Session Middleware Token Injection Vulnerability (critical 10.0)
- [CVE-2023-45128](https://insights.sbomify.com/CVE-2023-45128/): CSRF Token Reuse Vulnerability in fiber (critical 10.0)
- [CVE-2024-25124](https://insights.sbomify.com/CVE-2024-25124/): Fiber has Insecure CORS Configuration, Allowing Wildcard Origin with Credentials (critical 9.4)
- [CVE-2025-66630](https://insights.sbomify.com/CVE-2025-66630/): Fiber insecurely fallsback in utils.UUIDv4() / utils.UUID() — predictable / zero‑UUID on crypto/rand failure (critical 9.2)
- [CVE-2023-45141](https://insights.sbomify.com/CVE-2023-45141/): CSRF Token Validation Vulnerability in fiber (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54801 and fix it if it is affected.

What it is: CVE-2025-54801 is a high-severity denial of service vulnerability in gofiber fiber, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54801 exists.

Affected packages and fixed versions:
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.52.9
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.52.9
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.52.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54801/ (Markdown: https://insights.sbomify.com/CVE-2025-54801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54801
- OSV: https://osv.dev/vulnerability/CVE-2025-54801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54801/
Summaries are generated and may contain mistakes; the official description above is the record.
