# CVE-2025-54803: js-toml is vulnerable to Prototype Pollution

> A remote attacker can pollute the global Object prototype via malicious TOML input, potentially leading to code execution or privilege escalation.

- **Severity:** High 7.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2025
- **Updated:** 5 Aug 2025
- **Also known as:** GHSA-65fc-cr5f-v7r2

## What is CVE-2025-54803?

CVE-2025-54803 is a high-severity vulnerability in sunnyadn js-toml, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

js-toml is a TOML parser for JavaScript, fully compliant with the TOML 1.0.0 Spec. In versions below 1.0.2, a prototype pollution vulnerability in js-toml allows a remote attacker to add or modify properties of the global Object.prototype by parsing a maliciously crafted TOML input. This is fixed in version 1.0.2.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-54803?

2 open source packages ship an affected version, including js-toml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `js-toml` | npm | All versions | 1.0.2 |
| `js-toml` | npm | All versions | 1.0.2 |

Products: Sunnyadn Js-Toml.

## How do I fix CVE-2025-54803?

Upgrade js-toml to 1.0.2 or later.

## Is CVE-2025-54803 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54803 exists.

## Other vulnerabilities in sunnyadn js-toml

- [CVE-2026-49293](https://insights.sbomify.com/CVE-2026-49293/): CPU exhaustion via O(n^2) BigInt construction on radix-prefixed integer literals (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54803 and fix it if it is affected.

What it is: CVE-2025-54803 is a high-severity vulnerability in sunnyadn js-toml, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54803 exists.

Affected packages and fixed versions:
- js-toml (npm): affected all versions; fixed in 1.0.2
- js-toml (npm): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54803/ (Markdown: https://insights.sbomify.com/CVE-2025-54803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54803
- OSV: https://osv.dev/vulnerability/CVE-2025-54803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54803/
Summaries are generated and may contain mistakes; the official description above is the record.
