{"answers":{"affected":"2 open source packages ship an affected version, including russh. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54804 exists.","fix":"Upgrade russh to 0.54.1 or later.","what":"CVE-2025-54804 is a medium-severity vulnerability in Eugeny russh, published on 5 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54804 and fix it if it is affected.\n\nWhat it is: CVE-2025-54804 is a medium-severity vulnerability in Eugeny russh, published on 5 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54804 exists.\n\nAffected packages and fixed versions:\n- russh (crates.io): affected all versions; fixed in 0.54.1\n- russh (crates.io): affected all versions; fixed in 0.54.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54804/ (Markdown: https://insights.sbomify.com/CVE-2025-54804/index.md)","id":"CVE-2025-54804","markdown":"https://insights.sbomify.com/CVE-2025-54804/index.md","name":"CVE-2025-54804","record":{"aliases":["GHSA-h5rc-j5f5-3gcm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust SSH library","requires_auth":"low_privilege","summary":"A malicious client can crash an SSH server by triggering an integer overflow in the channel window adjustment logic of the Russh library.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"russh","vendor":"russh_project"},{"product":"warpgate","vendor":"warpgate_project"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Russh is a Rust SSH client \u0026 server library. In versions 0.54.0 and below, the channel window adjust message of the SSH protocol is used to track the free space in the receive buffer of the other side of a channel. The current implementation takes the value from the message and adds it to an internal state value. This can result in a integer overflow. If the Rust code is compiled with overflow checks, it will panic. A malicious client can crash a server. This is fixed in version 0.54.1.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Russh is missing an overflow check during channel windows adjust","id":"CVE-2025-54804","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"integer_overflow","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"TMM Vulnerability","id":"CVE-2025-54805"},"packages":[{"ecosystem":"crates.io","fixed":["0.54.1"],"introduced":["0"],"last_affected":[],"package":"russh","purl":null,"source":"GHSA-h5rc-j5f5-3gcm"},{"ecosystem":"crates.io","fixed":["0.54.1"],"introduced":["0"],"last_affected":[],"package":"russh","purl":"pkg:cargo/russh","source":"GHSA-h5rc-j5f5-3gcm"}],"prev":{"headline":"js-toml is vulnerable to Prototype Pollution","id":"CVE-2025-54803"},"products":["russh"],"published":"2025-08-05","related":[{"cvss_score":7.5,"headline":"Russh: Pre-auth DoS via unbounded allocation in keyboard-interactive auth","id":"CVE-2026-42189","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":7.5,"headline":"Russh has an OOM Denial of Service due to allocation of untrusted amount","id":"CVE-2024-43410","kev_date_added":null,"published":"2024-08-21"},{"cvss_score":5.9,"headline":"russh may use insecure Diffie-Hellman keys","id":"CVE-2023-28113","kev_date_added":null,"published":"2023-03-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-05","vendors":["Eugeny"]},"summary":"A malicious client can crash an SSH server by triggering an integer overflow in the channel window adjustment logic of the Russh library.","url":"https://insights.sbomify.com/CVE-2025-54804/"}