{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-54812 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-54812 is a low-severity cross-site scripting vulnerability in Apache Log4cxx, published on 22 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-54812 and fix it if it is affected.\n\nWhat it is: CVE-2025-54812 is a low-severity cross-site scripting vulnerability in Apache Log4cxx, published on 22 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-54812 in the wild and no public exploit code.\n\nAffected product: Apache Log4cxx. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54812/ (Markdown: https://insights.sbomify.com/CVE-2025-54812/index.md)","id":"CVE-2025-54812","markdown":"https://insights.sbomify.com/CVE-2025-54812/index.md","name":"CVE-2025-54812","record":{"aliases":["DEBIAN-CVE-2025-54812","GHSA-7mpr-gcjx-jcmw","UBUNTU-CVE-2025-54812","openSUSE-SU-2025:15549-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"C++ logging library","requires_auth":"none","summary":"Attackers can inject HTML or JavaScript into log files via untrusted logger names when HTMLLayout is used, potentially stealing data or hiding information.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"log4cxx","vendor":"apache"}],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-117","name":"Improper Output Neutralization for Logs"}],"description":"Improper Output Neutralization for Logs vulnerability in Apache Log4cxx.\n\nWhen using HTMLLayout, logger names are not properly escaped when writing out to the HTML file.\nIf untrusted data is used to retrieve the name of a logger, an attacker could theoretically inject HTML or Javascript in order to hide information from logs or steal data from the user.\nIn order to activate this, the following sequence must occur:\n\n  *  Log4cxx is configured to use HTMLLayout.\n\n  *  Logger name comes from an untrusted string\n\n  *  Logger with compromised name logs a message\n\n  *  User opens the generated HTML log file in their browser, leading to potential XSS\n\nBecause logger names are generally constant strings, we assess the impact to users as LOW\n\nThis issue affects Apache Log4cxx: before 1.5.0.\n\nUsers are recommended to upgrade to version 1.5.0, which fixes the issue.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Log4cxx: Improper HTML escaping in HTMLLayout","id":"CVE-2025-54812","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":1,"n_references":3,"next":{"headline":"Apache Log4cxx: Improper escaping with JSONLayout","id":"CVE-2025-54813"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.5.0-1.1"],"introduced":["0"],"last_affected":[],"package":"log4cxx","purl":"pkg:rpm/opensuse/log4cxx\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15549-1"}],"prev":{"headline":"OpenPLC_V3","id":"CVE-2025-54811"},"products":["Apache Log4cxx"],"published":"2025-08-22","related":[{"cvss_score":8.8,"headline":"Apache Log4cxx: SQL injection when using ODBC appender","id":"CVE-2023-31038","kev_date_added":null,"published":"2023-05-08"},{"cvss_score":6.3,"headline":"Other in Apache Log4cxx","id":"CVE-2026-40023","kev_date_added":null,"published":"2026-04-10"},{"cvss_score":6.3,"headline":"Apache Log4cxx: Improper escaping with JSONLayout","id":"CVE-2025-54813","kev_date_added":null,"published":"2025-08-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Apache Software Foundation"]},"summary":"Attackers can inject HTML or JavaScript into log files via untrusted logger names when HTMLLayout is used, potentially stealing data or hiding information.","url":"https://insights.sbomify.com/CVE-2025-54812/"}