CVE-2025-54831 Apache Airflow: Connection sensitive details exposed to users with READ permissions

Medium 6.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2025-54831?

CVE-2025-54831 is a medium-severity vulnerability in Apache Airflow, published on 26 Sep 2025.

Official description

Apache Airflow 3 introduced a change to the handling of sensitive information in Connections. The intent was to restrict access to sensitive connection fields to Connection Editing Users, effectively applying a "write-only" model for sensitive values.

In Airflow 3.0.3, this model was unintentionally violated: sensitive connection information could be viewed by users with READ permissions through both the API and the UI. This behavior also bypassed the `AIRFLOW__CORE__HIDE_SENSITIVE_VAR_CONN_FIELDS` configuration option.

This issue does not affect Airflow 2.x, where exposing sensitive information to connection editors was the intended and documented behavior.

Users of Airflow 3.0.3 are advised to upgrade Airflow to >=3.0.4.

Weakness: CWE-213

Which versions are affected by CVE-2025-54831?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIAll versions to 3.0.3-NANone
apache-airflow PyPIFrom 3.0.33.0.4
apache-airflow PyPIFrom 3.0.33.0.4
airflow BitnamiFrom 3.0.33.0.4

Products include Apache Airflow.

How do I fix CVE-2025-54831?

Upgrade apache-airflow to 3.0.4 or later.

Is CVE-2025-54831 being exploited?

There is no known exploitation of CVE-2025-54831 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2025-54831, GHSA-q475-2pgm-7hvp, PYSEC-2025-85.

Is CVE-2025-54831 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free