{"answers":{"affected":"2 open source packages ship an affected version, including youki. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-54867 in the wild and no public exploit code.","fix":"Upgrade youki to 0.5.5 or later.","what":"CVE-2025-54867 is a high-severity path traversal vulnerability in youki-dev youki, published on 14 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54867 and fix it if it is affected.\n\nWhat it is: CVE-2025-54867 is a high-severity path traversal vulnerability in youki-dev youki, published on 14 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54867 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- youki (crates.io): affected all versions; fixed in 0.5.5\n- youki (crates.io): affected all versions; fixed in 0.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54867/ (Markdown: https://insights.sbomify.com/CVE-2025-54867/index.md)","id":"CVE-2025-54867","markdown":"https://insights.sbomify.com/CVE-2025-54867/index.md","name":"CVE-2025-54867","record":{"aliases":["GHSA-j26p-6wx7-f3pw"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Youki container runtime","requires_auth":"low_privilege","summary":"Attackers can exploit symbolic links in the rootfs to access the host filesystem, leading to privilege escalation and data exposure.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"youki","vendor":"youki-dev"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-61","name":"UNIX Symbolic Link (Symlink) Following"}],"description":"Youki is a container runtime written in Rust. Prior to version 0.5.5, if /proc and /sys in the rootfs are symbolic links, they can potentially be exploited to gain access to the host root filesystem. This issue has been patched in version 0.5.5.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Youki Symlink Following Vulnerability","id":"CVE-2025-54867","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"LibreChat exposes arbitrary chats through Meilisearch engine","id":"CVE-2025-54868"},"packages":[{"ecosystem":"crates.io","fixed":["0.5.5"],"introduced":["0"],"last_affected":[],"package":"youki","purl":null,"source":"GHSA-j26p-6wx7-f3pw"},{"ecosystem":"crates.io","fixed":["0.5.5"],"introduced":["0"],"last_affected":[],"package":"youki","purl":"pkg:cargo/youki","source":"GHSA-j26p-6wx7-f3pw"}],"prev":{"headline":"Wazuh installation fails to protected authd.pass on Windows","id":"CVE-2025-54866"},"products":["youki"],"published":"2025-08-14","related":[{"cvss_score":7.3,"headline":"youki container escape via \"masked path\" abuse due to mount race conditions","id":"CVE-2025-62161","kev_date_added":null,"published":"2025-11-05"},{"cvss_score":7.3,"headline":"youki container escape and denial of service due to arbitrary write gadgets and procfs write redirects","id":"CVE-2025-62596","kev_date_added":null,"published":"2025-11-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-14","vendors":["youki-dev"]},"summary":"Attackers can exploit symbolic links in the rootfs to access the host filesystem, leading to privilege escalation and data exposure.","url":"https://insights.sbomify.com/CVE-2025-54867/"}