# CVE-2025-54867: Youki Symlink Following Vulnerability

> Attackers can exploit symbolic links in the rootfs to access the host filesystem, leading to privilege escalation and data exposure.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Aug 2025
- **Updated:** 14 Aug 2025
- **Also known as:** GHSA-j26p-6wx7-f3pw

## What is CVE-2025-54867?

CVE-2025-54867 is a high-severity path traversal vulnerability in youki-dev youki, published on 14 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Youki is a container runtime written in Rust. Prior to version 0.5.5, if /proc and /sys in the rootfs are symbolic links, they can potentially be exploited to gain access to the host root filesystem. This issue has been patched in version 0.5.5.

Weakness: CWE-61 (UNIX Symbolic Link (Symlink) Following)

## Which versions are affected by CVE-2025-54867?

2 open source packages ship an affected version, including youki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `youki` | crates.io | All versions | 0.5.5 |
| `youki` | crates.io | All versions | 0.5.5 |

Products: Youki-Dev Youki.

## How do I fix CVE-2025-54867?

Upgrade youki to 0.5.5 or later.

## Is CVE-2025-54867 being exploited?

There is no known exploitation of CVE-2025-54867 in the wild and no public exploit code.

## Other vulnerabilities in youki-dev youki

- [CVE-2025-62161](https://insights.sbomify.com/CVE-2025-62161/): youki container escape via "masked path" abuse due to mount race conditions (high 7.3)
- [CVE-2025-62596](https://insights.sbomify.com/CVE-2025-62596/): youki container escape and denial of service due to arbitrary write gadgets and procfs write redirects (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54867 and fix it if it is affected.

What it is: CVE-2025-54867 is a high-severity path traversal vulnerability in youki-dev youki, published on 14 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54867 in the wild and no public exploit code.

Affected packages and fixed versions:
- youki (crates.io): affected all versions; fixed in 0.5.5
- youki (crates.io): affected all versions; fixed in 0.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54867/ (Markdown: https://insights.sbomify.com/CVE-2025-54867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54867
- OSV: https://osv.dev/vulnerability/CVE-2025-54867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54867/
Summaries are generated and may contain mistakes; the official description above is the record.
