# CVE-2025-54868: LibreChat exposes arbitrary chats through Meilisearch engine

> An exposed testing endpoint in LibreChat allows attackers to read arbitrary user chats from the Meilisearch engine without authentication.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Aug 2025
- **Updated:** 5 Aug 2025
- **Also known as:** GHSA-p5j8-m4wh-ffmw

## What is CVE-2025-54868?

CVE-2025-54868 is a high-severity missing authorization vulnerability in Librechat Librechat, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LibreChat is a ChatGPT clone with additional features. In versions 0.0.6 through 0.7.7-rc1, an exposed testing endpoint allows reading arbitrary chats directly from the Meilisearch engine. The endpoint /api/search/test allows for direct access to stored chats in the Meilisearch engine without proper access control. This results in the ability to read chats from arbitrary users. This issue is fixed in version 0.7.7.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-54868?

It affects 1 product.


Products: Librechat Librechat.

## How do I fix CVE-2025-54868?

No fix has been published for CVE-2025-54868 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54868 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54868 exists.

## Other vulnerabilities in Librechat Librechat

- [CVE-2026-32625](https://insights.sbomify.com/CVE-2026-32625/): LibreChat Exfiltrates Server Secrets via MCP Server URL Injection (critical 9.6)
- [CVE-2024-11167](https://insights.sbomify.com/CVE-2024-11167/): Improper Access Control in danny-avila/librechat (critical 9.4)
- [CVE-2026-22252](https://insights.sbomify.com/CVE-2026-22252/): LibreChat MCP Stdio Remote Command Execution (critical 9.1)
- [CVE-2025-69222](https://insights.sbomify.com/CVE-2025-69222/): LibreChat is vulnerable to Server-Side Request Forgery due to missing restrictions (critical 9.1)
- [CVE-2024-41704](https://insights.sbomify.com/CVE-2024-41704/): Path traversal in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54868 and fix it if it is affected.

What it is: CVE-2025-54868 is a high-severity missing authorization vulnerability in Librechat Librechat, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54868 exists.

Affected product: Librechat Librechat. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54868/ (Markdown: https://insights.sbomify.com/CVE-2025-54868/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54868
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54868
- OSV: https://osv.dev/vulnerability/CVE-2025-54868

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54868/
Summaries are generated and may contain mistakes; the official description above is the record.
