CVE-2025-54869 FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser

Medium 6.0 Published Updated

Attackers can cause server crashes via memory exhaustion by uploading malicious PDFs to applications using the FPDI library.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-54869?

CVE-2025-54869 is a medium-severity denial of service vulnerability in Setasign FPDI, published on 5 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.

Weakness: CWE-770

Which versions are affected by CVE-2025-54869?

2 open source packages ship an affected version, including setasign/fpdi.

PackageAffectedFixed in
setasign/fpdi PackagistAll versions2.6.4
setasign/fpdi PackagistAll versions2.6.4

How do I fix CVE-2025-54869?

Upgrade setasign/fpdi to 2.6.4 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-54869 being exploited?

There is no known exploitation of CVE-2025-54869 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2025-54869, GHSA-jxhh-4648-vpp3, UBUNTU-CVE-2025-54869.

Is CVE-2025-54869 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free