{"answers":{"affected":"2 open source packages ship an affected version, including setasign/fpdi.","exploited":"There is no known exploitation of CVE-2025-54869 in the wild and no public exploit code.","fix":"Upgrade setasign/fpdi to 2.6.4 or later.","what":"CVE-2025-54869 is a medium-severity denial of service vulnerability in Setasign FPDI, published on 5 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54869 and fix it if it is affected.\n\nWhat it is: CVE-2025-54869 is a medium-severity denial of service vulnerability in Setasign FPDI, published on 5 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54869 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- setasign/fpdi (Packagist): affected all versions; fixed in 2.6.4\n- setasign/fpdi (Packagist): affected all versions; fixed in 2.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54869/ (Markdown: https://insights.sbomify.com/CVE-2025-54869/index.md)","id":"CVE-2025-54869","markdown":"https://insights.sbomify.com/CVE-2025-54869/index.md","name":"CVE-2025-54869","record":{"aliases":["DEBIAN-CVE-2025-54869","GHSA-jxhh-4648-vpp3","UBUNTU-CVE-2025-54869"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP PDF library","requires_auth":"low_privilege","summary":"Attackers can cause server crashes via memory exhaustion by uploading malicious PDFs to applications using the FPDI library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser","id":"CVE-2025-54869","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"VTun-ng's failure to initialize encryption modules may cause reversion to plaintext","id":"CVE-2025-54870"},"packages":[{"ecosystem":"Packagist","fixed":["2.6.4"],"introduced":["0"],"last_affected":[],"package":"setasign/fpdi","purl":null,"source":"GHSA-jxhh-4648-vpp3"},{"ecosystem":"Packagist","fixed":["2.6.4"],"introduced":["0"],"last_affected":[],"package":"setasign/fpdi","purl":"pkg:composer/setasign/fpdi","source":"GHSA-jxhh-4648-vpp3"}],"prev":{"headline":"LibreChat exposes arbitrary chats through Meilisearch engine","id":"CVE-2025-54868"},"products":["FPDI"],"published":"2025-08-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-07","vendors":["Setasign"]},"summary":"Attackers can cause server crashes via memory exhaustion by uploading malicious PDFs to applications using the FPDI library.","url":"https://insights.sbomify.com/CVE-2025-54869/"}