# CVE-2025-54869: FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser

> Attackers can cause server crashes via memory exhaustion by uploading malicious PDFs to applications using the FPDI library.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2025
- **Updated:** 7 Aug 2025
- **Also known as:** DEBIAN-CVE-2025-54869, GHSA-jxhh-4648-vpp3, UBUNTU-CVE-2025-54869

## What is CVE-2025-54869?

CVE-2025-54869 is a medium-severity denial of service vulnerability in Setasign FPDI, published on 5 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-54869?

2 open source packages ship an affected version, including setasign/fpdi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `setasign/fpdi` | Packagist | All versions | 2.6.4 |
| `setasign/fpdi` | Packagist | All versions | 2.6.4 |

## How do I fix CVE-2025-54869?

Upgrade setasign/fpdi to 2.6.4 or later.

## Is CVE-2025-54869 being exploited?

There is no known exploitation of CVE-2025-54869 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54869 and fix it if it is affected.

What it is: CVE-2025-54869 is a medium-severity denial of service vulnerability in Setasign FPDI, published on 5 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54869 in the wild and no public exploit code.

Affected packages and fixed versions:
- setasign/fpdi (Packagist): affected all versions; fixed in 2.6.4
- setasign/fpdi (Packagist): affected all versions; fixed in 2.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54869/ (Markdown: https://insights.sbomify.com/CVE-2025-54869/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54869
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54869
- OSV: https://osv.dev/vulnerability/CVE-2025-54869

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54869/
Summaries are generated and may contain mistakes; the official description above is the record.
