# CVE-2025-54870: VTun-ng's failure to initialize encryption modules may cause reversion to plaintext

> Attackers can intercept plaintext traffic if encryption initialization fails, affecting users of VTun-ng virtual tunnels.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Aug 2025
- **Updated:** 5 Aug 2025
- **Also known as:** GHSA-m3jc-27c6-2wrf

## What is CVE-2025-54870?

CVE-2025-54870 is a high-severity vulnerability in leakingmemory vtun-ng, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

VTun-ng is a Virtual Tunnel over TCP/IP network. In versions 3.0.17 and below, failure to initialize encryption modules might cause reversion to plaintext due to insufficient error handling. The bug was first introduced in VTun-ng version 3.0.12. This is fixed in version 3.0.18. To workaround this issue, avoid blowfish-256.

Weakness: CWE-636 (Not Failing Securely)

## Which versions are affected by CVE-2025-54870?


## How do I fix CVE-2025-54870?

No fix has been published for CVE-2025-54870 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54870 being exploited?

There is no known exploitation of CVE-2025-54870 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54870 and fix it if it is affected.

What it is: CVE-2025-54870 is a high-severity vulnerability in leakingmemory vtun-ng, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54870 in the wild and no public exploit code.

Affected product: leakingmemory vtun-ng. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54870/ (Markdown: https://insights.sbomify.com/CVE-2025-54870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54870
- OSV: https://osv.dev/vulnerability/CVE-2025-54870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54870/
Summaries are generated and may contain mistakes; the official description above is the record.
