# CVE-2025-54878: Heap Buffer Overflow in NASA CryptoLib 1.4.0 `Crypto_TC_Check_IV_Setup`

> A heap buffer overflow in NASA CryptoLib allows attackers to corrupt memory via crafted telecommand frames, potentially causing crashes or code execution.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Aug 2025
- **Updated:** 11 Aug 2025
- **Also known as:** GHSA-9qph-pxfm-q9g4

## What is CVE-2025-54878?

CVE-2025-54878 is a high-severity memory corruption vulnerability in nasa CryptoLib, published on 11 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CryptoLib provides a software-only solution using the CCSDS Space Data Link Security Protocol - Extended Procedures (SDLS-EP) to secure communications between a spacecraft running the core Flight System (cFS) and a ground station. A heap buffer overflow vulnerability exists in NASA CryptoLib version 1.4.0 and prior in the IV setup logic for telecommand frames. The problem arises from missing bounds checks when copying the Initialization Vector (IV) into a freshly allocated buffer. An attacker can supply a crafted TC frame that causes the library to write one byte past the end of the heap buffer, leading to heap corruption and undefined behaviour. An attacker supplying a malformed telecommand frame can corrupt heap memory. This leads to undefined behaviour, which could manifest itself as a crash (denial of service) or more severe exploitation. This issue has been patched in version 1.4.0.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2025-54878?

It affects 1 product.


Products: Nasa Cryptolib.

## How do I fix CVE-2025-54878?

No fix has been published for CVE-2025-54878 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54878 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54878 exists.

## Other vulnerabilities in nasa CryptoLib

- [CVE-2025-30216](https://insights.sbomify.com/CVE-2025-30216/): CryptoLib Has Heap Overflow in Crypto_TM_ProcessSecurity due to Unchecked Secondary Header Length (critical 9.4)
- [CVE-2025-30356](https://insights.sbomify.com/CVE-2025-30356/): Heap Buffer Overflow via Incomplete Length Check in `Crypto_TC_ApplySecurity` (critical 9.3)
- [CVE-2025-29909](https://insights.sbomify.com/CVE-2025-29909/): CryptoLib's Crypto_TC_ApplySecurity() Has a Heap Buffer Overflow Vulnerability (high 8.9)
- [CVE-2025-29911](https://insights.sbomify.com/CVE-2025-29911/): CryptoLib Has Heap Buffer Overflow in Crypto_AOS_ProcessSecurity Function (high 8.9)
- [CVE-2025-29912](https://insights.sbomify.com/CVE-2025-29912/): CryptoLib Has Heap Buffer Overflow Due to Unsigned Integer Underflow in Crypto_TC_ProcessSecurity (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54878 and fix it if it is affected.

What it is: CVE-2025-54878 is a high-severity memory corruption vulnerability in nasa CryptoLib, published on 11 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54878 exists.

Affected product: nasa CryptoLib. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54878/ (Markdown: https://insights.sbomify.com/CVE-2025-54878/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54878
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54878
- OSV: https://osv.dev/vulnerability/CVE-2025-54878

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54878/
Summaries are generated and may contain mistakes; the official description above is the record.
