# CVE-2025-54879: Mastodon e‑mail throttle misconfiguration allows unlimited email confirmations against unconfirmed emails

> Attackers can bypass email confirmation rate limits to spam users and overwhelm mail queues, requiring administrators to upgrade Mastodon.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2025
- **Updated:** 6 Aug 2025
- **Also known as:** BIT-mastodon-2025-54879, GHSA-84ch-6436-c7mg

## What is CVE-2025-54879?

CVE-2025-54879 is a medium-severity vulnerability in mastodon, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mastodon is a free, open-source social network server based on ActivityPub Mastodon which facilitates LDAP configuration for authentication. In versions 3.1.5 through 4.2.24, 4.3.0 through 4.3.11 and 4.4.0 through 4.4.3, Mastodon's rate-limiting system has a critical configuration error where the email-based throttle for confirmation emails incorrectly checks the password reset path instead of the confirmation path, effectively disabling per-email limits for confirmation requests. This allows attackers to bypass rate limits by rotating IP addresses and send unlimited confirmation emails to any email address, as only a weak IP-based throttle (25 requests per 5 minutes) remains active. The vulnerability enables denial-of-service attacks that can overwhelm mail queues and facilitate user harassment through confirmation email spam. This is fixed in versions 4.2.24, 4.3.11 and 4.4.3.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-54879?

1 open source package ship an affected version, including mastodon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mastodon` | Bitnami | From 3.1.5 | 4.2.24, 4.3.11, 4.4.3 |

Products: Joinmastodon Mastodon.

## How do I fix CVE-2025-54879?

Upgrade mastodon to a fixed version for your release line: 4.2.24, 4.3.11 or 4.4.3.

## Is CVE-2025-54879 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54879 exists.

## Other vulnerabilities in mastodon

- [CVE-2023-36460](https://insights.sbomify.com/CVE-2023-36460/): Mastodon vulnerable to arbitrary file creation through media attachments (critical 10.0)
- [CVE-2022-2166](https://insights.sbomify.com/CVE-2022-2166/): Improper Restriction of Excessive Authentication Attempts in mastodon/mastodon (critical 9.8)
- [CVE-2022-24307](https://insights.sbomify.com/CVE-2022-24307/): Missing authorization in n/a (critical 9.8)
- [CVE-2018-21018](https://insights.sbomify.com/CVE-2018-21018/): Auth bypass in n/a (critical 9.8)
- [CVE-2024-23832](https://insights.sbomify.com/CVE-2024-23832/): Mastodon Remote user impersonation and takeover (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54879 and fix it if it is affected.

What it is: CVE-2025-54879 is a medium-severity vulnerability in mastodon, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54879 exists.

Affected packages and fixed versions:
- mastodon (Bitnami): affected from 3.1.5; fixed in 4.2.24, 4.3.11, 4.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54879/ (Markdown: https://insights.sbomify.com/CVE-2025-54879/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54879
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54879
- OSV: https://osv.dev/vulnerability/CVE-2025-54879

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54879/
Summaries are generated and may contain mistakes; the official description above is the record.
