CVE-2025-54880 Mermaid does not properly sanitize architecture diagram iconText leading to XSS

Medium 5.1 Published Updated

Attackers can execute arbitrary scripts via unsanitized icon text in architecture diagrams, affecting users of the Mermaid JavaScript library.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-54880?

CVE-2025-54880 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 19 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Mermaid is a JavaScript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. In the default configuration of mermaid 11.9.0 and earlier, user supplied input for architecture diagram icons is passed to the d3 html() method, creating a sink for cross site scripting. This vulnerability is fixed in 11.10.0.

Weakness: CWE-79

Which versions are affected by CVE-2025-54880?

2 open source packages ship an affected version, including mermaid. It affects 1 product.

PackageAffectedFixed in
mermaid npmFrom 11.1.011.10.0
mermaid npmFrom 11.1.011.10.0

Products include Mermaid Project Mermaid.

How do I fix CVE-2025-54880?

Upgrade mermaid to 11.10.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-54880 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54880 exists.

Sources

Also known as GHSA-8gwm-58g9-j8pw, UBUNTU-CVE-2025-54880.

Is CVE-2025-54880 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free