# CVE-2025-54880: Mermaid does not properly sanitize architecture diagram iconText leading to XSS

> Attackers can execute arbitrary scripts via unsanitized icon text in architecture diagrams, affecting users of the Mermaid JavaScript library.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Aug 2025
- **Updated:** 19 Aug 2025
- **Also known as:** GHSA-8gwm-58g9-j8pw, UBUNTU-CVE-2025-54880

## What is CVE-2025-54880?

CVE-2025-54880 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 19 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mermaid is a JavaScript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. In the default configuration of mermaid 11.9.0 and earlier, user supplied input for architecture diagram icons is passed to the d3 html() method, creating a sink for cross site scripting. This vulnerability is fixed in 11.10.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-54880?

2 open source packages ship an affected version, including mermaid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mermaid` | npm | From 11.1.0 | 11.10.0 |
| `mermaid` | npm | From 11.1.0 | 11.10.0 |

Products: Mermaid Project Mermaid.

## How do I fix CVE-2025-54880?

Upgrade mermaid to 11.10.0 or later.

## Is CVE-2025-54880 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54880 exists.

## Other vulnerabilities in mermaid-js mermaid

- [CVE-2021-43861](https://insights.sbomify.com/CVE-2021-43861/): Incorrect sanitisation function leads to `XSS` (high 7.2)
- [CVE-2021-35513](https://insights.sbomify.com/CVE-2021-35513/): Cross-site Scripting in Mermaid (medium 6.1)
- [CVE-2026-41150](https://insights.sbomify.com/CVE-2026-41150/): Mermaid Gantt Charts are vulnerable to an Infinite Loop DoS (medium 5.3)
- [CVE-2026-41159](https://insights.sbomify.com/CVE-2026-41159/): Mermaid: Improper sanitization of configuration leads to CSS injection (medium 5.3)
- [CVE-2022-31108](https://insights.sbomify.com/CVE-2022-31108/): Arbitrary `CSS` injection into the generated graph affecting the container HTML in mermaid.js (medium 4.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54880 and fix it if it is affected.

What it is: CVE-2025-54880 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 19 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54880 exists.

Affected packages and fixed versions:
- mermaid (npm): affected from 11.1.0; fixed in 11.10.0
- mermaid (npm): affected from 11.1.0; fixed in 11.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54880/ (Markdown: https://insights.sbomify.com/CVE-2025-54880/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54880
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54880
- OSV: https://osv.dev/vulnerability/CVE-2025-54880

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54880/
Summaries are generated and may contain mistakes; the official description above is the record.
