CVE-2025-54883 Vision UI's security-kit Contains Cryptographic Weakness
A cryptographic weakness in Vision UI's security-kit allows predictable random number generation, potentially compromising security features relying on randomness.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-54883?
CVE-2025-54883 is a critical vulnerability in DavidOsipov Vision-ui, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vision UI is a collection of enterprise-grade, dependency-free modules for modern web projects. In versions 1.4.0 and below, the getSecureRandomInt function in security-kit versions prior to 3.5.0 (packaged in Vision-ui <= 1.4.0) contains a critical cryptographic weakness. Due to a silent 32-bit integer overflow in its internal masking logic, the function fails to produce a uniform distribution of random numbers when the requested range between min and max is larger than 2³². The root cause is the use of a 32-bit bitwise left-shift operation (<<) to generate a bitmask for the rejection sampling algorithm. This causes the mask to be incorrect for any range requiring 32 or more bits of entropy. This issue is fixed in version 1.5.0.
Weakness: CWE-338
Which versions are affected by CVE-2025-54883?
How do I fix CVE-2025-54883?
No fix has been published for CVE-2025-54883 yet. Limit exposure of the affected software until one is available.
Is CVE-2025-54883 being exploited?
There is no known exploitation of CVE-2025-54883 in the wild and no public exploit code.
Sources
Also known as GHSA-c9xg-x7h3-mq2q.