# CVE-2025-54883: Vision UI's security-kit Contains Cryptographic Weakness

> A cryptographic weakness in Vision UI's security-kit allows predictable random number generation, potentially compromising security features relying on randomness.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Aug 2025
- **Updated:** 6 Aug 2025
- **Also known as:** GHSA-c9xg-x7h3-mq2q

## What is CVE-2025-54883?

CVE-2025-54883 is a critical vulnerability in DavidOsipov Vision-ui, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vision UI is a collection of enterprise-grade, dependency-free modules for modern web projects. In versions 1.4.0 and below, the getSecureRandomInt function in security-kit versions prior to 3.5.0 (packaged in Vision-ui <= 1.4.0) contains a critical cryptographic weakness. Due to a silent 32-bit integer overflow in its internal masking logic, the function fails to produce a uniform distribution of random numbers when the requested range between min and max is larger than 2³². The root cause is the use of a 32-bit bitwise left-shift operation (<<) to generate a bitmask for the rejection sampling algorithm. This causes the mask to be incorrect for any range requiring 32 or more bits of entropy. This issue is fixed in version 1.5.0.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG))

## Which versions are affected by CVE-2025-54883?


## How do I fix CVE-2025-54883?

No fix has been published for CVE-2025-54883 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54883 being exploited?

There is no known exploitation of CVE-2025-54883 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54883 and fix it if it is affected.

What it is: CVE-2025-54883 is a critical vulnerability in DavidOsipov Vision-ui, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54883 in the wild and no public exploit code.

Affected product: DavidOsipov Vision-ui. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54883/ (Markdown: https://insights.sbomify.com/CVE-2025-54883/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54883
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54883
- OSV: https://osv.dev/vulnerability/CVE-2025-54883

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54883/
Summaries are generated and may contain mistakes; the official description above is the record.
