CVE-2025-54884 Vision UI security-kit.js: Potential Uncontrolled Resource Allocation Vulnerability
Attackers can cause denial of service by exhausting server memory or CPU through uncontrolled resource allocation in Vision UI security-kit functions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-54884?
CVE-2025-54884 is a high-severity denial of service vulnerability in DavidOsipov Vision-ui, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vision UI is a collection of enterprise-grade, dependency-free modules for modern web projects. In versions 1.4.0 and below, the generateSecureId and getSecureRandomInt functions in security-kit versions prior to 3.5.0 (packaged in Vision UI 1.4.0 and below) are vulnerable to Denial of Service (DoS) attacks. The generateSecureId(length) function directly used the length parameter to size a Uint8Array buffer, allowing attackers to exhaust server memory through repeated requests for large IDs since the previous 1024 limit was insufficient. The getSecureRandomInt(min, max) function calculated buffer size based on the range between min and max, where large ranges caused excessive memory allocation and CPU-intensive rejection-sampling loops that could hang the thread. This issue is fixed in version 1.5.0.
Which versions are affected by CVE-2025-54884?
How do I fix CVE-2025-54884?
No fix has been published for CVE-2025-54884 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-54884 being exploited?
There is no known exploitation of CVE-2025-54884 in the wild and no public exploit code.
Sources
Also known as GHSA-gg28-wc2c-jjj3.