{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-54884 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-54884 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-54884 is a high-severity denial of service vulnerability in DavidOsipov Vision-ui, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54884 and fix it if it is affected.\n\nWhat it is: CVE-2025-54884 is a high-severity denial of service vulnerability in DavidOsipov Vision-ui, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54884 in the wild and no public exploit code.\n\nAffected product: DavidOsipov Vision-ui. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54884/ (Markdown: https://insights.sbomify.com/CVE-2025-54884/index.md)","id":"CVE-2025-54884","markdown":"https://insights.sbomify.com/CVE-2025-54884/index.md","name":"CVE-2025-54884","record":{"aliases":["GHSA-gg28-wc2c-jjj3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Vision UI security-kit","requires_auth":"none","summary":"Attackers can cause denial of service by exhausting server memory or CPU through uncontrolled resource allocation in Vision UI security-kit functions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Vision UI is a collection of enterprise-grade, dependency-free modules for modern web projects. In versions 1.4.0 and below, the generateSecureId and getSecureRandomInt functions in security-kit versions prior to 3.5.0 (packaged in Vision UI 1.4.0 and below) are vulnerable to Denial of Service (DoS) attacks. The generateSecureId(length) function directly used the length parameter to size a Uint8Array buffer, allowing attackers to exhaust server memory through repeated requests for large IDs since the previous 1024 limit was insufficient. The getSecureRandomInt(min, max) function calculated buffer size based on the range between min and max, where large ranges caused excessive memory allocation and CPU-intensive rejection-sampling loops that could hang the thread. This issue is fixed in version 1.5.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Vision UI security-kit.js: Potential Uncontrolled Resource Allocation Vulnerability","id":"CVE-2025-54884","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"Thinbus generates insufficient entropy: 252 bits vs minimum 256 bits","id":"CVE-2025-54885"},"packages":[],"prev":{"headline":"Vision UI's security-kit Contains Cryptographic Weakness","id":"CVE-2025-54883"},"products":["Vision-ui"],"published":"2025-08-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-06","vendors":["DavidOsipov"]},"summary":"Attackers can cause denial of service by exhausting server memory or CPU through uncontrolled resource allocation in Vision UI security-kit functions.","url":"https://insights.sbomify.com/CVE-2025-54884/"}