# CVE-2025-54884: Vision UI security-kit.js: Potential Uncontrolled Resource Allocation Vulnerability

> Attackers can cause denial of service by exhausting server memory or CPU through uncontrolled resource allocation in Vision UI security-kit functions.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Aug 2025
- **Updated:** 6 Aug 2025
- **Also known as:** GHSA-gg28-wc2c-jjj3

## What is CVE-2025-54884?

CVE-2025-54884 is a high-severity denial of service vulnerability in DavidOsipov Vision-ui, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vision UI is a collection of enterprise-grade, dependency-free modules for modern web projects. In versions 1.4.0 and below, the generateSecureId and getSecureRandomInt functions in security-kit versions prior to 3.5.0 (packaged in Vision UI 1.4.0 and below) are vulnerable to Denial of Service (DoS) attacks. The generateSecureId(length) function directly used the length parameter to size a Uint8Array buffer, allowing attackers to exhaust server memory through repeated requests for large IDs since the previous 1024 limit was insufficient. The getSecureRandomInt(min, max) function calculated buffer size based on the range between min and max, where large ranges caused excessive memory allocation and CPU-intensive rejection-sampling loops that could hang the thread. This issue is fixed in version 1.5.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-54884?


## How do I fix CVE-2025-54884?

No fix has been published for CVE-2025-54884 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54884 being exploited?

There is no known exploitation of CVE-2025-54884 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54884 and fix it if it is affected.

What it is: CVE-2025-54884 is a high-severity denial of service vulnerability in DavidOsipov Vision-ui, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54884 in the wild and no public exploit code.

Affected product: DavidOsipov Vision-ui. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54884/ (Markdown: https://insights.sbomify.com/CVE-2025-54884/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54884
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54884
- OSV: https://osv.dev/vulnerability/CVE-2025-54884

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54884/
Summaries are generated and may contain mistakes; the official description above is the record.
