CVE-2025-54885 Thinbus generates insufficient entropy: 252 bits vs minimum 256 bits

Medium 6.9 Published Updated

Insufficient entropy in client key generation reduces security margin, potentially allowing attackers to bypass authentication in the Thinbus SRP library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-54885?

CVE-2025-54885 is a medium-severity vulnerability in simbo1905 thinbus-srp-npm, published on 7 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Thinbus Javascript Secure Remote Password is a browser SRP6a implementation for zero-knowledge password authentication. In versions 2.0.0 and below, a protocol compliance bug causes the client to generate a fixed 252 bits of entropy instead of the intended bit length of the safe prime (defaulted to 2048 bits). The client public value is being generated from a private value that is 4 bits below the specification. This reduces the protocol's designed security margin it is now practically exploitable. The servers full sized 2048 bit random number is used to create the shared session key and password proof. This is fixed in version 2.0.1.

Weakness: CWE-331

Which versions are affected by CVE-2025-54885?

2 open source packages ship an affected version, including thinbus-srp.

PackageAffectedFixed in
thinbus-srp npmAll versions2.0.1
thinbus-srp npmAll versions2.0.1

How do I fix CVE-2025-54885?

Upgrade thinbus-srp to 2.0.1 or later.

Is CVE-2025-54885 being exploited?

There is no known exploitation of CVE-2025-54885 in the wild and no public exploit code.

Sources

Also known as GHSA-8q6v-474h-whgg.

Is CVE-2025-54885 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free