{"answers":{"affected":"2 open source packages ship an affected version, including thinbus-srp.","exploited":"There is no known exploitation of CVE-2025-54885 in the wild and no public exploit code.","fix":"Upgrade thinbus-srp to 2.0.1 or later.","what":"CVE-2025-54885 is a medium-severity vulnerability in simbo1905 thinbus-srp-npm, published on 7 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54885 and fix it if it is affected.\n\nWhat it is: CVE-2025-54885 is a medium-severity vulnerability in simbo1905 thinbus-srp-npm, published on 7 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54885 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- thinbus-srp (npm): affected all versions; fixed in 2.0.1\n- thinbus-srp (npm): affected all versions; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54885/ (Markdown: https://insights.sbomify.com/CVE-2025-54885/index.md)","id":"CVE-2025-54885","markdown":"https://insights.sbomify.com/CVE-2025-54885/index.md","name":"CVE-2025-54885","record":{"aliases":["GHSA-8q6v-474h-whgg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript SRP library","requires_auth":"none","summary":"Insufficient entropy in client key generation reduces security margin, potentially allowing attackers to bypass authentication in the Thinbus SRP library.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-331","name":"Insufficient Entropy"}],"description":"Thinbus Javascript Secure Remote Password is a browser SRP6a implementation for zero-knowledge password authentication. In versions 2.0.0 and below, a protocol compliance bug causes the client to generate a fixed 252 bits of entropy instead of the intended bit length of the safe prime (defaulted to 2048 bits). The client public value is being generated from a private value that is 4 bits below the specification. This reduces the protocol's designed security margin it is now practically exploitable. The servers full sized 2048 bit random number is used to create the shared session key and password proof. This is fixed in version 2.0.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Thinbus generates insufficient entropy: 252 bits vs minimum 256 bits","id":"CVE-2025-54885","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"weak_cryptography","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"skops: Card.get_model does not block arbitrary code execution","id":"CVE-2025-54886"},"packages":[{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"thinbus-srp","purl":null,"source":"GHSA-8q6v-474h-whgg"},{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"thinbus-srp","purl":"pkg:npm/thinbus-srp","source":"GHSA-8q6v-474h-whgg"}],"prev":{"headline":"Vision UI security-kit.js: Potential Uncontrolled Resource Allocation Vulnerability","id":"CVE-2025-54884"},"products":["thinbus-srp-npm"],"published":"2025-08-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-07","vendors":["simbo1905"]},"summary":"Insufficient entropy in client key generation reduces security margin, potentially allowing attackers to bypass authentication in the Thinbus SRP library.","url":"https://insights.sbomify.com/CVE-2025-54885/"}