# CVE-2025-54885: Thinbus generates insufficient entropy: 252 bits vs minimum 256 bits

> Insufficient entropy in client key generation reduces security margin, potentially allowing attackers to bypass authentication in the Thinbus SRP library.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2025
- **Updated:** 7 Aug 2025
- **Also known as:** GHSA-8q6v-474h-whgg

## What is CVE-2025-54885?

CVE-2025-54885 is a medium-severity vulnerability in simbo1905 thinbus-srp-npm, published on 7 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Thinbus Javascript Secure Remote Password is a browser SRP6a implementation for zero-knowledge password authentication. In versions 2.0.0 and below, a protocol compliance bug causes the client to generate a fixed 252 bits of entropy instead of the intended bit length of the safe prime (defaulted to 2048 bits). The client public value is being generated from a private value that is 4 bits below the specification. This reduces the protocol's designed security margin it is now practically exploitable. The servers full sized 2048 bit random number is used to create the shared session key and password proof. This is fixed in version 2.0.1.

Weakness: CWE-331 (Insufficient Entropy)

## Which versions are affected by CVE-2025-54885?

2 open source packages ship an affected version, including thinbus-srp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thinbus-srp` | npm | All versions | 2.0.1 |
| `thinbus-srp` | npm | All versions | 2.0.1 |

## How do I fix CVE-2025-54885?

Upgrade thinbus-srp to 2.0.1 or later.

## Is CVE-2025-54885 being exploited?

There is no known exploitation of CVE-2025-54885 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54885 and fix it if it is affected.

What it is: CVE-2025-54885 is a medium-severity vulnerability in simbo1905 thinbus-srp-npm, published on 7 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54885 in the wild and no public exploit code.

Affected packages and fixed versions:
- thinbus-srp (npm): affected all versions; fixed in 2.0.1
- thinbus-srp (npm): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54885/ (Markdown: https://insights.sbomify.com/CVE-2025-54885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54885
- OSV: https://osv.dev/vulnerability/CVE-2025-54885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54885/
Summaries are generated and may contain mistakes; the official description above is the record.
