# CVE-2025-54886: skops: Card.get_model does not block arbitrary code execution

> Attackers can execute arbitrary code by providing non-zip model files, as the library silently falls back to unsafe joblib loading instead of secure skops validation.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Aug 2025
- **Updated:** 8 Aug 2025
- **Also known as:** GHSA-378x-6p4f-8jgm, PYSEC-2026-1925

## What is CVE-2025-54886?

CVE-2025-54886 is a high-severity unsafe deserialization vulnerability in skops-dev skops, published on 8 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

skops is a Python library which helps users share and ship their scikit-learn based models. In versions 0.12.0 and below, the Card.get_model does not contain any logic to prevent arbitrary code execution. The Card.get_model function supports both joblib and skops for model loading. When loading .skops models, it uses skops' secure loading with trusted type validation, raising errors for untrusted types unless explicitly allowed. However, when non-.zip file formats are provided, the function silently falls back to joblib without warning. Unlike skops, joblib allows arbitrary code execution during loading, bypassing security measures and potentially enabling malicious code execution. This issue is fixed in version 0.13.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-54886?

3 open source packages ship an affected version, including skops.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `skops` | PyPI | All versions | 0.13.0 |
| `skops` | PyPI | All versions | 0.13.0 |
| `skops` | PyPI | All versions | 0.13.0 |

## How do I fix CVE-2025-54886?

Upgrade skops to 0.13.0 or later.

## Is CVE-2025-54886 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54886 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54886 and fix it if it is affected.

What it is: CVE-2025-54886 is a high-severity unsafe deserialization vulnerability in skops-dev skops, published on 8 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54886 exists.

Affected packages and fixed versions:
- skops (PyPI): affected all versions; fixed in 0.13.0
- skops (PyPI): affected all versions; fixed in 0.13.0
- skops (PyPI): affected all versions; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54886/ (Markdown: https://insights.sbomify.com/CVE-2025-54886/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54886
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54886
- OSV: https://osv.dev/vulnerability/CVE-2025-54886

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54886/
Summaries are generated and may contain mistakes; the official description above is the record.
