{"answers":{"affected":"2 open source packages ship an affected version, including jwe.","exploited":"There is no known exploitation of CVE-2025-54887 in the wild and no public exploit code.","fix":"Upgrade jwe to 1.1.1 or later.","what":"CVE-2025-54887 is a critical vulnerability in jwt ruby-jwe, published on 8 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54887 and fix it if it is affected.\n\nWhat it is: CVE-2025-54887 is a critical vulnerability in jwt ruby-jwe, published on 8 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54887 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jwe (RubyGems): affected all versions; fixed in 1.1.1\n- jwe (RubyGems): affected all versions; fixed in 1.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54887/ (Markdown: https://insights.sbomify.com/CVE-2025-54887/index.md)","id":"CVE-2025-54887","markdown":"https://insights.sbomify.com/CVE-2025-54887/index.md","name":"CVE-2025-54887","record":{"aliases":["GHSA-c7p4-hx26-pr73"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby JWE library","requires_auth":"none","summary":"Missing AES-GCM tag validation in the Ruby JWE library allows attackers to decrypt or forge tokens, compromising confidentiality and integrity.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-354","name":"Improper Validation of Integrity Check Value"}],"description":"jwe is a Ruby implementation of the RFC 7516 JSON Web Encryption (JWE) standard. In versions 1.1.0 and below, authentication tags of encrypted JWEs can be brute forced, which may result in loss of confidentiality for those JWEs and provide ways to craft arbitrary JWEs. This puts users at risk because JWEs can be modified to decrypt to an arbitrary value, decrypted by observing parsing differences and the GCM internal GHASH key can be recovered. Users are affected by this vulnerability even if they do not use an AES-GCM encryption algorithm for their JWEs. As the GHASH key may have been leaked, users must rotate the encryption keys after upgrading. This issue is fixed in version 1.1.1.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":"2025-08-12","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-08-12T15:22:41Z","kind":"github_poc","ref":"https://github.com/shinigami-777/PoC_CVE-2025-54887","stars":0,"title":"Proof of Concept for CVE-2025-54887"}],"tier":"poc_unverified"},"has_fix":true,"headline":"jwe: Missing AES-GCM authentication tag validation in encrypted JWEs","id":"CVE-2025-54887","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"weak_cryptography","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"@fedify/fedify: Improper Authentication and Incorrect Authorization","id":"CVE-2025-54888"},"packages":[{"ecosystem":"RubyGems","fixed":["1.1.1"],"introduced":["0"],"last_affected":[],"package":"jwe","purl":null,"source":"GHSA-c7p4-hx26-pr73"},{"ecosystem":"RubyGems","fixed":["1.1.1"],"introduced":["0"],"last_affected":[],"package":"jwe","purl":"pkg:gem/jwe","source":"GHSA-c7p4-hx26-pr73"}],"prev":{"headline":"skops: Card.get_model does not block arbitrary code execution","id":"CVE-2025-54886"},"products":["ruby-jwe"],"published":"2025-08-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-08","vendors":["jwt"]},"summary":"Missing AES-GCM tag validation in the Ruby JWE library allows attackers to decrypt or forge tokens, compromising confidentiality and integrity.","url":"https://insights.sbomify.com/CVE-2025-54887/"}