# CVE-2025-54887: jwe: Missing AES-GCM authentication tag validation in encrypted JWEs

> Missing AES-GCM tag validation in the Ruby JWE library allows attackers to decrypt or forge tokens, compromising confidentiality and integrity.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Aug 2025
- **Updated:** 8 Aug 2025
- **Also known as:** GHSA-c7p4-hx26-pr73

## What is CVE-2025-54887?

CVE-2025-54887 is a critical vulnerability in jwt ruby-jwe, published on 8 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jwe is a Ruby implementation of the RFC 7516 JSON Web Encryption (JWE) standard. In versions 1.1.0 and below, authentication tags of encrypted JWEs can be brute forced, which may result in loss of confidentiality for those JWEs and provide ways to craft arbitrary JWEs. This puts users at risk because JWEs can be modified to decrypt to an arbitrary value, decrypted by observing parsing differences and the GCM internal GHASH key can be recovered. Users are affected by this vulnerability even if they do not use an AES-GCM encryption algorithm for their JWEs. As the GHASH key may have been leaked, users must rotate the encryption keys after upgrading. This issue is fixed in version 1.1.1.

Weakness: CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2025-54887?

2 open source packages ship an affected version, including jwe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jwe` | RubyGems | All versions | 1.1.1 |
| `jwe` | RubyGems | All versions | 1.1.1 |

## How do I fix CVE-2025-54887?

Upgrade jwe to 1.1.1 or later.

## Is CVE-2025-54887 being exploited?

There is no known exploitation of CVE-2025-54887 in the wild and no public exploit code.

Public exploit code:

- Proof of Concept for CVE-2025-54887 (github_poc): https://github.com/shinigami-777/PoC_CVE-2025-54887

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54887 and fix it if it is affected.

What it is: CVE-2025-54887 is a critical vulnerability in jwt ruby-jwe, published on 8 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54887 in the wild and no public exploit code.

Affected packages and fixed versions:
- jwe (RubyGems): affected all versions; fixed in 1.1.1
- jwe (RubyGems): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54887/ (Markdown: https://insights.sbomify.com/CVE-2025-54887/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54887
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54887
- OSV: https://osv.dev/vulnerability/CVE-2025-54887

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54887/
Summaries are generated and may contain mistakes; the official description above is the record.
